|Cc:||andres <andres(at)anarazel(dot)de>, michael <michael(at)paquier(dot)xyz>, pgsql-hackers <pgsql-hackers(at)postgresql(dot)org>, ahsan(dot)hadi <ahsan(dot)hadi(at)highgo(dot)ca>|
|Subject:||Re: Wrong statistics for size of XLOG_SWITCH during pg_waldump.|
|Views:||Raw Message | Whole Thread | Download mbox | Resend email|
Thanks for all the suggestion, and new patch attached.
>Andres suggested that we don't need that description with per-record
>basis. Do you have a reason to do that? (For clarity, I'm not
>suggesting that you should reving it.)
I think Andres is saying if we just log it in xlog_desc() then we can not get
the result for '--stats=record' case. And the patch solve the problem.
>+ XLByteToSeg(record->EndRecPtr - 1, endSegNo, record->segcxt.ws_segsize);
>We use XLByteToPrevSeg instead for this purpose.
Thanks and follow the suggestion.
>You forgot to add a correction for short headers.
Infact, we need to consider this matter when the remain size of a wal
segment can not afford a XLogRecord struct for XLOG_SWITCH.
It's mean that if record->ReadRecPtr is on A wal segment, then
record->EndRecPtr is on (A+2) wal segment. So we need to minus
the longpagehead size on (A+1) wal segment.
In my thought we need not to care the short header, if my understand
>+ if(RM_XLOG_ID == rmid && XLOG_SWITCH == info)
>We need a comment for the special code path.
>We don't follow this kind of convension. Rather use "variable =
>+ junk_len = xlog_switch_junk_len(record);
>+ stats->junk_size += junk_len;
>junk_len is used only the last line above. We don't need that
>+ * If the wal switch record spread on two segments, we should extra minus the
>This comment is sticking out of 80-column border. However, I'm not
>sure if we have reached a conclustion about the target console-width.
>+ info = (rj << 4) & ~XLR_INFO_MASK;
>+ switch_junk_id = "XLOG/SWITCH_JUNK";
>+ if( XLOG_SWITCH == info && stats->count_xlog_switch > 0)
>This line order is strange. At least switch_junk_id is used only in
>the if-then block.
Thanks and follow the suggestions.
>I'm not confindent on which is better, but I feel that this is not a
>work for display side, but for the recorder side like attached.
The patch really seems more clearly, but the new 'OTHERS' may confuse
the users and we hard to handle it with '--rmgr=RMGR' option. So I have
not use this design in this patch, let's see other's opinion.
>Sorry for the confusion, but it would be a separate topic even if we
>are going to fix that..
Sorry, I remove the code, make sense we should discuss it in a
Highgo Software (Canada/China/Pakistan)
URL : www.highgo.ca
|Next Message||Kyotaro Horiguchi||2020-10-16 08:36:28||Re: Enumize logical replication message actions|
|Previous Message||Pavel Stehule||2020-10-16 08:11:48||Re: [PATCH] Add extra statistics to explain for Nested Loop|