|From:||Michael Paquier <michael(at)paquier(dot)xyz>|
|To:||Postgres hackers <pgsql-hackers(at)lists(dot)postgresql(dot)org>|
|Cc:||Thomas Munro <thomas(dot)munro(at)gmail(dot)com>|
|Subject:||pg_stat_wal_receiver and flushedUpto/writtenUpto|
|Views:||Raw Message | Whole Thread | Download mbox | Resend email|
As discussed in the thread that introduced d140f2f3 to rename
receivedUpto to flushedUpto and add writtenUpto to the WAL receiver's
shared memory information, the equivalent columns in
pg_stat_wal_receiver have not been renamed:
When I have implemented this system view, the idea was to keep a
one-one mapping between the SQL interface and the shmem info even if
we are not compatible with past versions, hence I think that before
beta1 we had better fix that and:
- rename received_lsn to flushed_lsn.
- add one column for writtenUpto.
Attached is a patch to do that. This needs also a catalog version
bump, and I am adding an open item.
|Next Message||Dilip Kumar||2020-05-15 09:17:27||Re: PATCH: logical_work_mem and logical streaming of large in-progress transactions|
|Previous Message||Andrey M. Borodin||2020-05-15 09:01:46||Re: MultiXact\SLRU buffers configuration|