Re: Should we rename amapi.h and amapi.c?

From: Michael Paquier <michael(at)paquier(dot)xyz>
To: Ashwin Agrawal <aagrawal(at)pivotal(dot)io>
Cc: Postgres hackers <pgsql-hackers(at)lists(dot)postgresql(dot)org>
Subject: Re: Should we rename amapi.h and amapi.c?
Date: 2019-12-24 02:57:12
Views: Raw Message | Whole Thread | Download mbox | Resend email
Lists: pgsql-hackers

On Mon, Dec 23, 2019 at 12:28:36PM -0800, Ashwin Agrawal wrote:
> I had raised the same earlier and [1] has response from Andres, which was
> "We probably should rename it, but not in 12..."
> [1]

Okay, glad to see that this has been mentioned. So let's do some
renaming for v13 then. I have studied first if we had better remove
amapi.c, then move amvalidate() to amvalidate.c and the handler lookup
routine to indexam.c as it already exists, but keeping things ordered
as they are makes sense to limit spreading too much dependencies with
the syscache mainly, so instead the attached patch does the following
- amapi.h -> indexam.h
- amapi.c -> indexamapi.c. Here we have an equivalent in access/table/
as tableamapi.c.
- amvalidate.c -> indexamvalidate.c
- amvalidate.h -> indexamvalidate.h
- genam.c -> indexgenam.c

Please note that we have also amcmds.c and amcmds.c in the code, but
the former could be extended to have utilities for table AMs, and the
latter applies to both, so they are better left untouched in my

Attachment Content-Type Size
0001-Rename-files-and-headers-related-to-index-AM.patch text/x-diff 60.9 KB

In response to


Browse pgsql-hackers by date

  From Date Subject
Next Message Michael Paquier 2019-12-24 03:22:13 Re: Increase footprint of %m and reduce strerror()
Previous Message Thomas Munro 2019-12-24 02:10:49 Re: Condition variables vs interrupts