Tom Lane wrote:
> Alvaro Herrera <alvherre(at)commandprompt(dot)com> writes:
> > Simon Riggs wrote:
> >> Methinks it should be: stats_<something>, so that people find it in the
> >> same place as stats_query_string, which is still there.
> > Hum, but the order in postgresql.conf is arbitrary, right?
> I concur with Simon that it should have some relationship to
> stats_query_string. However, stats_collection doesn't appeal to me
> because that sounds like it would subsume stats_query_string (it seems
> like a master control toggle, as stats_start_collector used to be).
> Maybe something like stats_count_events?
> Or we could get radical and rename both of them...
Well, it is a bit misleading to have the query_string stuff be named
"stats" when it's not actually collected by pgstats at all. Maybe
rename it to "collect_query_string". With the other name being
"collect_stats", they would show up together in SHOW ALL.
I am not sure about using plural/singular though: why isn't it
"stats_query_strings" instead? (We do have "log_connections" etc).
Alvaro Herrera http://www.amazon.com/gp/registry/5ZYLFMCVHXC
"Porque francamente, si para saber manejarse a uno mismo hubiera que
rendir examen... ¿Quién es el machito que tendría carnet?" (Mafalda)
In response to
pgsql-hackers by date
|Next:||From: Oleg Bartunov||Date: 2007-07-31 18:28:26|
|Subject: Re: default_text_search_config and expression indexes|
|Previous:||From: Alvaro Herrera||Date: 2007-07-31 17:36:59|
|Subject: Re: stats_block_level|