Skip site navigation (1) Skip section navigation (2)

Re: getpid() function

From: nconway(at)klamath(dot)dyndns(dot)org (Neil Conway)
To: Bruce Momjian <pgman(at)candle(dot)pha(dot)pa(dot)us>
Cc: PostgreSQL-development <pgsql-hackers(at)postgreSQL(dot)org>
Subject: Re: getpid() function
Date: 2002-07-31 01:17:58
Message-ID: (view raw, whole thread or download thread mbox)
Lists: pgsql-generalpgsql-hackers
On Tue, Jul 30, 2002 at 08:40:13PM -0400, Bruce Momjian wrote:
> I have implemented this TODO item:
> 	* Add getpid() function to backend
> There were a large number of pg_stat functions that access pids and
> backends slots so I added it there:
> 	test=> select pg_stat_get_backend_mypid();

If we're going to add it to pg_stat_*, why is 'backend' part of the
name? All the existing backend_* function fetch some piece of data
about a given backend -- whereas this function does not (it takes
no arguments).

IMHO, a better name would be something like 'backend_process_id()',
or 'unix_pid', or 'backend_pid()'.

Also, can you add some documentation on this?



Neil Conway <neilconway(at)rogers(dot)com>

In response to


pgsql-hackers by date

Next:From: Bruce MomjianDate: 2002-07-31 01:48:42
Subject: Re: getpid() function
Previous:From: Matthew T. O'ConnorDate: 2002-07-31 01:09:01
Subject: Re: Why is MySQL more chosen over PostgreSQL?

pgsql-general by date

Next:From: Neil ConwayDate: 2002-07-31 01:28:09
Subject: Re: Have been accepted as a writer for "The Register"
Previous:From: Bruce MomjianDate: 2002-07-31 00:40:13
Subject: getpid() function

Privacy Policy | About PostgreSQL
Copyright © 1996-2017 The PostgreSQL Global Development Group