Skip site navigation (1) Skip section navigation (2)

Re: lock listing

From: nconway(at)klamath(dot)dyndns(dot)org (Neil Conway)
To: Bruce Momjian <pgman(at)candle(dot)pha(dot)pa(dot)us>
Cc: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>,PostgreSQL Patches <pgsql-patches(at)postgresql(dot)org>
Subject: Re: lock listing
Date: 2002-07-23 22:47:18
Message-ID: (view raw, whole thread or download thread mbox)
Lists: pgsql-patches
On Tue, Jul 23, 2002 at 05:52:39PM -0400, Bruce Momjian wrote:
> I agree with Peter that it is better to rename it pg_lock*.  The show
> isn't needed and it makes it look more like our other system info
> tables.

Well, it's not a system info table -- it's a built-in function, and I'm
not aware of any naming conventions for those. Personally, I find it a
bit confusing to do:

    SELECT * FROM pg_tables;
    SELECT * FROM pg_class;
    /* ... */
    SELECT * FROM pg_locks();

However, I'm not really worried about the name, so I've changed it
to pg_locks() -- a revised patch is attached.



Neil Conway <neilconway(at)rogers(dot)com>

In response to


pgsql-patches by date

Next:From: Bruce MomjianDate: 2002-07-23 23:13:52
Subject: Re: Fk fix for noaction update/delete
Previous:From: Bruce MomjianDate: 2002-07-23 22:18:16
Subject: Re: Table Function API doc patch

Privacy Policy | About PostgreSQL
Copyright © 1996-2017 The PostgreSQL Global Development Group