|From:||Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>|
|To:||Thomas Munro <thomas(dot)munro(at)gmail(dot)com>|
|Subject:||Re: Misleading comment about single_copy, and some bikeshedding|
|Views:||Raw Message | Whole Thread | Download mbox | Resend email|
Thomas Munro <thomas(dot)munro(at)gmail(dot)com> writes:
> Hmm. I wonder if we should rename force_parallel_mode to
> force_gather_node in v13. The current name has always seemed slightly
> misleading to me; it sounds like some kind of turbo boost button but
> really it's a developer-only test mode. Also, does it belong under
> DEVELOPER_OPTIONS instead of QUERY_TUNING_OTHER? I'm also wondering
> if the variable single_copy would be better named
> no_leader_participation or single_participant. I find "copy" a
> slightly strange way to refer to the number of copies *allowed to
> run*, but maybe that's just me.
FWIW, I agree 100% that these names are opaque. I don't know if your
suggestions are the best we can do, but they each seem like improvements.
And yes, force_parallel_mode should be under DEVELOPER_OPTIONS; it's a
performance-losing test option.
regards, tom lane
|Next Message||Peter Eisentraut||2019-06-24 15:53:39||Re: Do we need to do better for pg_ctl timeouts?|
|Previous Message||Andres Freund||2019-06-24 15:26:49||Re: Usage of epoch in txid_current|