> > This patch will implement the "ENABLE PRIVILEGE" and "DISABLE PRIVILEGE"
> > commands in PL/pgSQL, which, respectively, change the effective uid to that
> > of the function owner and back. It doesn't break security (I hope). The
> > commands can be abbreviated as "ENABLE" and "DISABLE" for the poor saps that
Anybody else want to object to this abbreviation idea ? Seems
reading ENABLE; or DISABLE; is very hard to interpret in source code
(enable what ?) and should thus not be allowed (or allow "ENABLE PRIV").
pgsql-hackers by date
|Next:||From: Zeugswetter Andreas SB||Date: 2001-06-25 10:17:10|
|Subject: AW: Good name for new lock type for VACUUM?|
|Previous:||From: Lincoln Yeoh||Date: 2001-06-25 06:34:51|
|Subject: Re: Encrypting pg_shadow passwords|