Skip site navigation (1) Skip section navigation (2)

Re: splitting htup.h

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Alvaro Herrera <alvherre(at)2ndquadrant(dot)com>
Cc: Pg Hackers <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: splitting htup.h
Date: 2012-08-28 21:27:51
Message-ID: (view raw, whole thread or download thread mbox)
Lists: pgsql-hackers
Alvaro Herrera <alvherre(at)2ndquadrant(dot)com> writes:
> This patch is mainly doing four things:

> 1. take some typedefs and the HeapTupleData struct definition from
> access/htup.h, and put them in access/tupbasics.h.  This new file is
> used as #include in all headers instead of htup.h.

> I'm unsure about the "tupbasics.h" file name.  I'm open to better ideas.

I'd be inclined to keep the name "htup.h" for the more widely used file,
and invent a new name for what we're splitting out of it.  This should
reduce the number of changes needed, not only in our code but third
party code.  Not sure if the new file could sanely be called
"htup_private.h"; it seems a bit widely used for that.  Maybe "heap.h"?

Also, is there any reason to consider just moving those defs into
heapam.h, instead of inventing a new header?  I'm not sure if there's
any principled distinction between heap.h and heapam.h, or any
significant differences between their sets of consumers.

The other changes all sound sane.

			regards, tom lane

In response to


pgsql-hackers by date

Next:From: Christopher BrowneDate: 2012-08-28 21:30:53
Subject: Re: Audit Logs WAS: temporal support patch
Previous:From: Jim NasbyDate: 2012-08-28 21:06:42
Subject: Re: Audit Logs WAS: temporal support patch

Privacy Policy | About PostgreSQL
Copyright © 1996-2017 The PostgreSQL Global Development Group