Re: logical_replication_mode

From: Peter Eisentraut <peter(at)eisentraut(dot)org>
To: "Zhijie Hou (Fujitsu)" <houzj(dot)fnst(at)fujitsu(dot)com>, Amit Kapila <amit(dot)kapila16(at)gmail(dot)com>
Cc: pgsql-hackers <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: logical_replication_mode
Date: 2023-08-25 07:08:45
Views: Raw Message | Whole Thread | Download mbox | Resend email
Lists: pgsql-hackers

On 25.08.23 08:52, Zhijie Hou (Fujitsu) wrote:
> On Friday, August 25, 2023 12:28 PM Amit Kapila <amit(dot)kapila16(at)gmail(dot)com> wrote:
>> On Thu, Aug 24, 2023 at 12:45 PM Peter Eisentraut <peter(at)eisentraut(dot)org>
>> wrote:
>>> I suggest we rename this setting to something starting with debug_.
>>> Right now, the name looks much too tempting for users to fiddle with.
>>> I think this is similar to force_parallel_mode.
>> +1. How about debug_logical_replication?
>>> Also, the descriptions in guc_tables.c could be improved. For
>>> example,
>>> gettext_noop("Controls when to replicate or apply each change."),
>>> is pretty content-free and unhelpful.
>> The other possibility I could think of is to change short_desc as:
>> "Allows to replicate each change for large transactions.". Do you have any
>> better ideas?
> How about "Forces immediate streaming or serialization of changes in large
> transactions." which is similar to the description in document.
> I agree that renaming it to debug_xx would be better and
> here is a patch that tries to do this.

Maybe debug_logical_replication is too general? Something like
debug_logical_replication_streaming would be more concrete. (Or
debug_logical_streaming.) Is that an appropriate name for what it's doing?

In response to


Browse pgsql-hackers by date

  From Date Subject
Next Message Pavel Stehule 2023-08-25 07:12:20 Re: broken master regress tests
Previous Message Daniel Gustafsson 2023-08-25 07:00:24 Re: initdb caching during tests