RE: reloption to prevent VACUUM from truncating empty pages at the end of relation

From: "Tsunakawa, Takayuki" <tsunakawa(dot)takay(at)jp(dot)fujitsu(dot)com>
To: Michael Paquier <michael(at)paquier(dot)xyz>, 'Julien Rouhaud' <rjuju123(at)gmail(dot)com>
Cc: Laurenz Albe <laurenz(dot)albe(at)cybertec(dot)at>, "Jamison, Kirk" <k(dot)jamison(at)jp(dot)fujitsu(dot)com>, Alvaro Herrera <alvherre(at)2ndquadrant(dot)com>, "Amit Kapila" <amit(dot)kapila16(at)gmail(dot)com>, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>, Fujii Masao <masao(dot)fujii(at)gmail(dot)com>, pgsql-hackers <pgsql-hackers(at)postgresql(dot)org>
Subject: RE: reloption to prevent VACUUM from truncating empty pages at the end of relation
Date: 2019-02-25 02:38:05
Message-ID: 0A3221C70F24FB45833433255569204D1FBB2713@G01JPEXMBYT05
Views: Raw Message | Whole Thread | Download mbox
Thread:
Lists: pgsql-hackers

From: Michael Paquier [mailto:michael(at)paquier(dot)xyz]
> I don't think that we want to use a too generic name and it seems more natural
> to reflect the context where it is used in the parameter name.
> If we were to shrink with a similar option for other contexts, we would
> most likely use a different option. Depending on the load pattern, users
> should also be able to disable or enable a subset of contexts as well.
>
> So I agree with Julien that [auto]vacuum_shrink_enabled is more adapted
> for this stuff.

OK, I renamed it to vacuum_shrink_enabled.

From: Julien Rouhaud [mailto:rjuju123(at)gmail(dot)com]
> One last thing, I think we should at least add one regression test for
> this setting. The one you provided previously seems perfectly suited.

Thanks, added.

Regards
Takayuki Tsunakawa

Attachment Content-Type Size
disable-vacuum-truncation_v3.patch application/octet-stream 7.1 KB

In response to

Responses

Browse pgsql-hackers by date

  From Date Subject
Next Message Nagaura, Ryohei 2019-02-25 04:48:36 RE: Timeout parameters
Previous Message Thomas Munro 2019-02-25 01:13:11 Parallel query vs smart shutdown and Postmaster death