12th September 2019: PostgreSQL 12 Beta 4 Released!
Supported Versions: Current (11) / 10 / 9.6 / 9.5 / 9.4
Development Versions: 12 / devel
Unsupported versions: 9.3 / 9.2 / 9.1 / 9.0 / 8.4 / 8.3 / 8.2
This documentation is for an unsupported version of PostgreSQL.
You may want to view the same page for the current version, or one of the supported versions listed above instead.

55.5. Limitations

GIN assumes that indexable operators are strict. This means that extractValue will not be called at all on a NULL item value (instead, a placeholder index entry is created automatically), and extractQuery will not be called on a NULL query value either (instead, the query is presumed to be unsatisfiable). Note however that NULL key values contained within a non-null composite item or query value are supported.