Skip site navigation (1) Skip section navigation (2)

plperl won't load on Win2k3

From: "Raymond Auge" <RX_Auge(at)nickel(dot)laurentian(dot)ca>
To: <pgsql-admin(at)postgresql(dot)org>
Subject: plperl won't load on Win2k3
Date: 2004-10-18 18:36:54
Message-ID: s173d528.058@luadmn2.laurentian.ca (view raw or flat)
Thread:
Lists: pgsql-admin
Hello All,

I'd like to know what I am doing wrong. I've installed the 7.5 win32 version of Postgres (love it...). I've entered the bin directory and loaded the plpgsql language on my database (works fine)...

I have perl 5.6.1 installed as well and would like to load the plperl language on the db as well.

While in the %postgresql%\bin I try

>createlang plperl dbname
createlang: language installation failed: ERROR:  could not load library "C:/Pro
gram Files/PostgreSQL/7.5/lib/plperl.dll": error

The plperl.dll _IS_ there.

I've added the perl interpreted to the path, but thought that maybe I also need the perl libs on a lib path.

Can anyone say if this is correct and what how to set that value?



--------------------------------------------------------------
Raymond Augé, B.COSC
Spécialiste en médiatisation de la formation/Multimedia specialist
Université Laurentienne / Laurentian University
<rx_auge(at)laurentienne(dot)ca> / <rx_auge(at)laurentian(dot)ca> 
(705) 675-1151 x3934



pgsql-admin by date

Next:From: Chuming ChenDate: 2004-10-18 19:37:48
Subject: insert a file into remote database
Previous:From: Tom LaneDate: 2004-10-18 18:06:52
Subject: Re: Relations summary at end of vacuum

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group