Skip site navigation (1) Skip section navigation (2)

Re: Branch 1.14?

From: Jasmin Dizdarevic <jasmin(dot)dizdarevic(at)gmail(dot)com>
To: Guillaume Lelarge <guillaume(at)lelarge(dot)info>
Cc: Dave Page <dpage(at)pgadmin(dot)org>, "pgadmin-hackers(at)postgresql(dot)org" <pgadmin-hackers(at)postgresql(dot)org>
Subject: Re: Branch 1.14?
Date: 2011-06-15 10:27:48
Message-ID: BANLkTi=eCV7cHsZ_b9MrGCvGHEc_64n0vQ@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-hackers
2011/6/15 Guillaume Lelarge <guillaume(at)lelarge(dot)info>

> On Wed, 2011-06-15 at 10:00 +0200, Jasmin Dizdarevic wrote:
> > You're right. Patching very old releases will become more difficult.
> > But those patches are rare and most of the time not very large, so the
> > merge should not be a big problem.
>
> I'm not sure I understand. Do you mean that users will have to backpatch
>> some bugfixes and compile an old pgAdmin to be able to use old
>> PostgreSQL releases? I sincerely hope you don't mean that.
>
>
> No, of course. I wanted to say, that if we change the current code to much,
patching older versions with patches developed with the current head would
become more complicated - because there will probably be more conflicts and
so on.


> > Either one actual version of pgAdmin which supports everything back to
> > 7.3. or different versions which targets different postgresql
> > releases. Currently we have a hybrid - that's not very good, I think.
>
> We don't have both. We currently have a pgAdmin which supports
>> everything back to 7.3. And you cannot say otherwise, unless you know
>> some bugs you didn't report.
>
>
>  You don't like the idea to remove the old code from pgAdmin, but we have
older versions which are designed to work with older version of postgresql.
If there are any poor souls working with < 8.2, in my opinion they should
also use an older pgAdmin client - Dave described it in a later mail: they
must! So removing the old code wouldn't be so bad and it wouldn't break any
functionality.

 I'm saying we're not actively doing that, but if someone wants
> to do so, or if we want to simplify things when working on a
> particular piece of code, then removing the support for older versions
> is acceptable.


I agree to Dave's idea.

>
> --
> Guillaume
>  http://blog.guillaume.lelarge.info
>  http://www.dalibo.com
>
>

In response to

pgadmin-hackers by date

Next:From: Guillaume LelargeDate: 2011-06-15 11:01:31
Subject: Re: Branch 1.14?
Previous:From: Dave PageDate: 2011-06-15 10:11:19
Subject: Re: Branch 1.14?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group