Skip site navigation (1) Skip section navigation (2)

Re: No connection to a PG 8.0 Beta 1 win32 server

From: Richard Huxton <dev(at)archonet(dot)com>
To: Secrétariat <ets(at)rolland-fr(dot)com>
Cc: pgsql-general <pgsql-general(at)postgresql(dot)org>
Subject: Re: No connection to a PG 8.0 Beta 1 win32 server
Date: 2004-08-24 14:37:56
Message-ID: 412B52C4.3040402@archonet.com (view raw or flat)
Thread:
Lists: pgsql-general
Secrétariat wrote:
> I already receive 8 times this message, not responding to my question !
> The question is :
> Why when I enable "tcpip_socket = true" in the postgresql.conf it becomes
> impossible to restart the service ?! (so hosts conections are impossible).

If PostgreSQL won't start with tcpip_socket=true, but can otherwise then 
that suggests it can't open the socket.

That might be because something else is using it, or it might be because 
a firewall won't let you.

If something else is using the socket then by telnet-ing to port 5432 we 
can see what is there.

If you get different results trying to connect from different places 
then that would suggest a firewall is involved.

I'm assuming you have:
  1. Tried stopping and starting manually
  2. checked the logs and there is nothing there
  3. have run netstat and it doesn't show anything useful.

Given that you have done those, we need to start from outside and work in.

-- 
   Richard Huxton
   Archonet Ltd

In response to

Responses

pgsql-general by date

Next:From: Dave CramerDate: 2004-08-24 14:39:22
Subject: Re: No connection to a PG 8.0 Beta 1 win32 server
Previous:From: Josué MaldonadoDate: 2004-08-24 14:26:32
Subject: Re: pg_dump/psql fails on win32 beta 8.0

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group