Skip site navigation (1) Skip section navigation (2)

Re: Dynamic Array into pl/pgSQL function

From: Joe Conway <mail(at)joeconway(dot)com>
To: derrick <derrick(at)grifflink(dot)com>
Cc: olly(at)lfix(dot)co(dot)uk, pgsql-novice(at)postgresql(dot)org
Subject: Re: Dynamic Array into pl/pgSQL function
Date: 2004-05-31 23:53:11
Message-ID: 40BBC567.7090401@joeconway.com (view raw or flat)
Thread:
Lists: pgsql-novice
derrick wrote:
> There must be some kind of setting that needs to be set on my database that 
> isn't, because I have copied what you used nearly exactly, and I still get 
> this message: "WARNING:  line 4 at for over select rows  ERROR:  parser: 
> parse error at or near "$1" at character 55"

[...snip example...]
> Any other ideas? I'm using 7.4.2

I'd bet not. Show us the result of:

select version();

Your example works perfectly for me under 7.4.2, and gives the same 
error you see under 7.3.6.

HTH,

Joe



In response to

Responses

pgsql-novice by date

Next:From: Ilya S. SlyzhnyakDate: 2004-06-01 03:58:17
Subject: wikipedia article
Previous:From: derrickDate: 2004-05-31 23:15:50
Subject: Re: Dynamic Array into pl/pgSQL function

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group