Skip site navigation (1) Skip section navigation (2)

Re: weird problem with pgadmin & postgres on debian

From: "Dave Page" <dpage(at)vale-housing(dot)co(dot)uk>
To: <neurotrotter(at)gmail(dot)com>,<pgadmin-support(at)postgresql(dot)org>
Subject: Re: weird problem with pgadmin & postgres on debian
Date: 2006-03-18 13:48:28
Message-ID: 006d01c64a92$a8eaaeb0$6a01a8c0@valehousing.co.uk (view raw or flat)
Thread:
Lists: pgadmin-support
Are you sure you're starting the same installation/cluster? Manually/init shouldn't make any difference if so.

Regards, Dave

-----Original Message-----
From: "Alessandro @ GMail"<neurotrotter(at)gmail(dot)com>
Sent: 18/03/06 13:12:01
To: "pgadmin-support(at)postgresql(dot)org"<pgadmin-support(at)postgresql(dot)org>
Subject: Re: [pgadmin-support] weird problem with pgadmin & postgres on debian

ok, i fixed it by removing the postmaster daemon from init.d and starting postgres manually every time i need it, don't now why but it works, maybe it's a problem of user rights, but i'm too noob to know :P





----------------------------------------------------------------


	hello there, 
	
	(it's the first time i use a mailing list...wow!)
	So, here's my problem: 
	
	I've installed postgresql on debian as well as pgadmin(everything updated to last version).
	Now, when i try to access my server on localhost with pgadmin, i cannot enter because it asks me the password. But i have no password, as it's just a first-time learning-purpose install! If i simply leave the password field empty, it rejects my login( 
	"Error connecting to the server: fe_sendauth: no password supplied"
	). But, if i try to access the server with 'psql testdatabase' from a terminal, i am able to enter, and work normally.
	
	I've also installed postgresql & pgadmin on windows xp (database different from the linux one) and pgadmin acts normally, letting me login and managing databases without any problem.
	
	What's wrong?
	
	thx
	






-----Unmodified Original Message-----
ok, i fixed it by removing the postmaster daemon from init.d and starting postgres manually every time i need it, don't now why but it works, maybe it's a problem of user rights, but i'm too noob to know :P





----------------------------------------------------------------


	hello there, 
	
	(it's the first time i use a mailing list...wow!)
	So, here's my problem: 
	
	I've installed postgresql on debian as well as pgadmin(everything updated to last version).
	Now, when i try to access my server on localhost with pgadmin, i cannot enter because it asks me the password. But i have no password, as it's just a first-time learning-purpose install! If i simply leave the password field empty, it rejects my login( 
	"Error connecting to the server: fe_sendauth: no password supplied"
	). But, if i try to access the server with 'psql testdatabase' from a terminal, i am able to enter, and work normally.
	
	I've also installed postgresql & pgadmin on windows xp (database different from the linux one) and pgadmin acts normally, letting me login and managing databases without any problem.
	
	What's wrong?
	
	thx
	




Responses

pgadmin-support by date

Next:From: Alessandro @ GMailDate: 2006-03-18 17:25:32
Subject: Re: weird problem with pgadmin & postgres on debian
Previous:From: Alessandro @ GMailDate: 2006-03-18 13:11:40
Subject: Re: weird problem with pgadmin & postgres on debian

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group