Skip site navigation (1) Skip section navigation (2)

Re: Postgresql under cygwin just stopped working.

From: "Martin Husted Hartvig" <mh(at)ctek(dot)dk>
To: "pgsql-cygwin(at)postgresql(dot)org" <pgsql-cygwin(at)postgresql(dot)org>
Subject: Re: Postgresql under cygwin just stopped working.
Date: 2004-07-15 07:57:33
Message-ID: opsa55p7o9p11tu2@pasmtp.tele.dk (view raw or flat)
Thread:
Lists: pgsql-cygwin
As I had a backup of the databases I dropped the data folder and made a  
initdb, trying with both ipc-daemon and cygserver. When starting  
postgresql with ipc-daemon I got the same error, but starting with  
cygserver got me a little on the move with semmns and semmni error  
indications. When I changed the max_connections from 100 to 45 I was able  
to start postgresql and restore my databases from my backups. Could this  
have something to do with the Windows "secure" update from Microsoft?


Regards,
Martin


On Wed, 14 Jul 2004 23:38:44 -0500, mike g <mike(at)thegodshalls(dot)com> wrote:

> With 7.3.1 you really should be using cygserver instead of the
> ipc-daemon.  Was the cygserver config script run, installed as a
> service, and running?
>
> Perhaps double check the directory permissions in case the X
> installation changed any.
>
> Bad system call to me would indicate postgres is not able to request a
> program or file it needs.  It is the dam$ shmat error that no one seems
> to be able to solve.
>
> Reinstall cygwin as a last resort.
>
> HTH
>
> On Wed, 2004-07-14 at 07:20, Martin Husted Hartvig wrote:
>> Hello List,
>>
>> I have been using PostgreSQL under CygWin for some time now and have  
>> been
>> very glad, but this day it just stopped working. I can't see what the
>> problem is, but 3 things has happend since yesterday where is ran fine:
>>   1. I installed CygWin/X
>>   2. My my laptop did'nt wake up after hypernate so I had to turn it off
>>   3. I have just installed the Windows XP service upgrade
>>
>>
>> I was using the IPC daemon2 as an NT service, but I have also tryed  
>> using
>> the cygserver.
>>
>> When I try to start this happens:
>>
>> $postmaster -D /var/postgres/data/
>> Bad system call
>>
>>
>> and with debug level 5:
>>
>> $ postmaster -d 5 -D /var/postgres/data/
>> [4004] DEBUG:  postmaster: PostmasterMain: initial environ dump:
>> [4004] DEBUG:  -----------------------------------------
>> [4004] DEBUG:   !::=::\
>> [4004] DEBUG:   !C:=C:\cygwin\bin
>> [4004] DEBUG:   ALLUSERSPROFILE=C:\Documents and Settings\All Users
>> [4004] DEBUG:   ANT_HOME=C:\java\apache-ant-1.6.1
>> [4004] DEBUG:   APPDATA=C:\Documents and Settings\mh\Application Data
>> [4004] DEBUG:   CLIENTNAME=Console
>> [4004] DEBUG:   COMMONPROGRAMFILES=C:\Program Files\Common Files
>> [4004] DEBUG:   COMPUTERNAME=MH2
>> [4004] DEBUG:   COMSPEC=C:\WINDOWS\system32\cmd.exe
>> [4004] DEBUG:   CVS_RSH=/bin/ssh
>> [4004] DEBUG:   CYGSERVER=server
>> [4004] DEBUG:   CYGWIN=tty
>> [4004] DEBUG:   HOME=/home/mh
>> [4004] DEBUG:   HOMEDRIVE=C:
>> [4004] DEBUG:   HOMEPATH=\Documents and Settings\mh
>> [4004] DEBUG:   HOSTNAME=MH2
>> [4004] DEBUG:
>> INFOPATH=/usr/local/info:/usr/info:/usr/share/info:/usr/autotool
>> /devel/info:/usr/autotool/stable/info:
>> [4004] DEBUG:   JAVA_HOME=C:\j2sdk1.4.2
>> [4004] DEBUG:   LOGONSERVER=\\MH2
>> [4004] DEBUG:   MAKE_MODE=unix
>> [4004] DEBUG:
>> MANPATH=/usr/local/man:/usr/man:/usr/share/man:/usr/autotool/dev
>> el/man::/usr/ssl/man:/usr/X11R6/man
>> [4004] DEBUG:   NUMBER_OF_PROCESSORS=1
>> [4004] DEBUG:   OLDPWD=/usr/bin
>> [4004] DEBUG:   OS=Windows_NT
>> [4004] DEBUG:
>> PATH=/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/cygdrive/c/WIN
>> DOWS/system32:/cygdrive/c/WINDOWS:/cygdrive/c/WINDOWS/System32/Wbem:/cygdrive/c/
>> Program Files/Common Files/Adaptec
>> Shared/System:/cygdrive/c/PROGRA~1/ULTRAE~1:/
>> cygdrive/c/Program Files/nasm:/cygdrive/c/Program
>> Files/cdrecord:/cygdrive/c/j2s
>> dk1.4.2/bin:/cygdrive/c/java/apache-ant-1.6.1/bin:/usr/bin
>> [4004] DEBUG:   PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
>> [4004] DEBUG:   PKG_CONFIG_PATH=/usr/X11R6/lib/pkgconfig
>> [4004] DEBUG:   PROCESSOR_ARCHITECTURE=x86
>> [4004] DEBUG:   PROCESSOR_IDENTIFIER=x86 Family 6 Model 9 Stepping 5,
>> GenuineInt
>> el
>> [4004] DEBUG:   PROCESSOR_LEVEL=6
>> [4004] DEBUG:   PROCESSOR_REVISION=0905
>> [4004] DEBUG:   PROGRAMFILES=C:\Program Files
>> [4004] DEBUG:   PROMPT=$P$G
>> [4004] DEBUG:   PS1=\[\033]0;\w\007
>>          \033[32m\]\u(at)\h \[\033[33m\w\033[0m\]
>>          $
>> [4004] DEBUG:   PWD=/home/mh
>> [4004] DEBUG:   SESSIONNAME=Console
>> [4004] DEBUG:   SHLVL=1
>> [4004] DEBUG:   SYSTEMDRIVE=C:
>> [4004] DEBUG:   SYSTEMROOT=C:\WINDOWS
>> [4004] DEBUG:   TEMP=/cygdrive/c/DOCUME~1/mh/LOCALS~1/Temp
>> [4004] DEBUG:   TERM=cygwin
>> [4004] DEBUG:   TMP=/cygdrive/c/DOCUME~1/mh/LOCALS~1/Temp
>> [4004] DEBUG:   USER=mh
>> [4004] DEBUG:   USERDOMAIN=MH2
>> [4004] DEBUG:   USERNAME=mh
>> [4004] DEBUG:   USERPROFILE=C:\Documents and Settings\mh
>> [4004] DEBUG:   WINDIR=C:\WINDOWS
>> [4004] DEBUG:   _=/usr/bin/postmaster
>> [4004] DEBUG:   TZ=RST-1RST-2,M3.5.0/2,M10.5.0/3
>> [4004] DEBUG:  -----------------------------------------
>> [4004] DEBUG:  searching PATH for executable
>> [4004] DEBUG:  could not stat "/usr/local/bin/postgres": No such file or
>> directo
>> ry
>> [4004] DEBUG:  found "/usr/bin/postgres" using PATH
>> [4004] DEBUG:  invoking IpcMemoryCreate(size=10461184)
>> Bad system call
>>
>> I tryed reinstalling the postgresql packages (7.3.1) from cygwin, but I
>> have not ran a initdb yet. Any idea's?
>> I would be very glad for any reply that could help solving this. Thanks.
>>
>> Regards,
>> Martin
>>
>>
>> ---------------------------(end of broadcast)---------------------------
>> TIP 9: the planner will ignore your desire to choose an index scan if  
>> your
>>       joining column's datatypes do not match



-- 
Martin


In response to

Responses

pgsql-cygwin by date

Next:From: mike gDate: 2004-07-16 04:42:38
Subject: Re: Postgresql under cygwin just stopped working.
Previous:From: jithendra royDate: 2004-07-15 05:19:55
Subject: initdb failed

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group