Skip site navigation (1) Skip section navigation (2)

Re: [pgadmin-support] Refreshing removed object crashes pgadmin3

From: blacknoz(at)club-internet(dot)fr
To: saito(at)inetrt(dot)skcapi(dot)co(dot)jp, richard(dot)vandenberg(at)trust-factory(dot)com,pgadmin-support(at)postgresql(dot)org
Cc: pgadmin-hackers(at)postgresql(dot)org
Subject: Re: [pgadmin-support] Refreshing removed object crashes pgadmin3
Date: 2004-01-08 12:25:15
Message-ID: mnet2.1073561115.24784.blacknoz@club-internet.fr (view raw or flat)
Thread:
Lists: pgadmin-hackerspgadmin-support
Dear Richard, Hiroshi,

it seems that richard is using woody ( the debian stable release ). As I'm linking dynamically debian packages to postgre, I used the debian official postgresql package to build pgA3.

I saw the thread between Jean Michel Pouré and Andreas Pflug last  month concerning libpq issue (concluding to the necessity of a static linking of libpq) but did not get time to modify my packages. 

to pgadmin-hackers: 
Is it *really* a pre-req to use libpq >=7.3 ?

If yes, this a pure packaging issue we have here... I think I'll have to produce different packages for woody and for testing/unstable.
I would like to continue dynamic linking for testing and unstable as it's debian way to do the things.

Can others (on other distros) try to reproduce the bug signaled here ?

To Richard: I wait a bit for answers from others but will try a particular build for woody with static linking against a postgresql backport... that's quite a lot of work, so you'll have  to wait a little.

Regards,

Raphaël



----Message d'origine----
>De: "Hiroshi Saito" <saito(at)inetrt(dot)skcapi(dot)co(dot)jp>
>A: "Richard van den Berg" <richard(dot)vandenberg(at)trust-factory(dot)com>,
>Sujet: Re: [pgadmin-support] Refreshing removed object crashes pgadmin3
>Date: Thu, 8 Jan 2004 19:09:55 +0900
>
>Dear Richard.
>
>----- Original Message ----- 
>From: "Richard van den Berg" <richard(dot)vandenberg(at)trust-factory(dot)com>
>
>
>> Subject: Refreshing removed object crashes pgadmin3
>> Package: pgadmin3
>> Version: 1.0.2-0.1
>> Severity: important
>(snip)
>> ii  libpgsql2       7.2.1-2woody4 Shared library libpq.so.2 for Post
>      '''''''''''''''''''''''''''''''''''''''
>Hmm..
>Is PostgreSQL7.2.1 in your environment?
>It may be a problem he had libpq made as shared.
>pgAdmin3 requires libpq beyond PostgreSQL7.3.
>
>regards,
>Hiroshi Saito
>
>---------------------------(end of broadcast)---------------------------
>TIP 2: you can get off all lists at once with the unregister command
>    (send "unregister YourEmailAddressHere" to majordomo(at)postgresql(dot)org)
>
>


Responses

pgadmin-hackers by date

Next:From: Richard van den BergDate: 2004-01-08 15:13:54
Subject: Re: [pgadmin-support] Refreshing removed object crashes pgadmin3
Previous:From: Ângelo Marcos RigoDate: 2004-01-08 12:19:16
Subject: poedit.deb

pgadmin-support by date

Next:From: Richard van den BergDate: 2004-01-08 15:13:54
Subject: Re: [pgadmin-support] Refreshing removed object crashes pgadmin3
Previous:From: Andreas PflugDate: 2004-01-08 12:15:44
Subject: Re: [pgadmin-support] Refreshing removed object crashes pgadmin3

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group