Skip site navigation (1) Skip section navigation (2)

Re: Extension upgrade, patch v0: debug help needed

From: Dimitri Fontaine <dimitri(at)2ndQuadrant(dot)fr>
To: "David E(dot) Wheeler" <david(at)kineticode(dot)com>
Cc: Dimitri Fontaine <dimitri(at)2ndQuadrant(dot)fr>, PostgreSQL Hackers <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: Extension upgrade, patch v0: debug help needed
Date: 2011-01-03 19:49:44
Message-ID: m2tyhppy1z.fsf@2ndQuadrant.fr (view raw or flat)
Thread:
Lists: pgsql-hackers
"David E. Wheeler" <david(at)kineticode(dot)com> writes:
> I rather doubt that "WRAPPER" will be accepted as a reserved word in the grammar.

It's already in the grammar, and I didn't change its "level".

>> dim=# create wrapper extension lo;
>> CREATE EXTENSION
>
> What happened to your UPGRADE from NULL idea?

You upgrade an installed extension, right?

>> The WRAPPER keyword meaning is that we're only creating the catalog
>> entry, forcing version to NULL and not running the extension's script.
>> This keyword looked like the best choice from existing ones in our
>> grammar, please feel free to pick any other phrase here.
>
> I don't see why it's necessary at all.

Care to offer an alternative or go in any level of details about what
you have in mind and how *exactly* you think it should work?  I've not
been offered psychic powers this Christmas, sorry…

Regards,
-- 
Dimitri Fontaine
http://2ndQuadrant.fr     PostgreSQL : Expertise, Formation et Support

In response to

Responses

pgsql-hackers by date

Next:From: David E. WheelerDate: 2011-01-03 19:51:14
Subject: Re: Extension upgrade, patch v0: debug help needed
Previous:From: Dimitri FontaineDate: 2011-01-03 19:46:47
Subject: Re: Upgrading Extension, version numbers

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group