Skip site navigation (1) Skip section navigation (2)

Re: Getting "ident" to work in Windows

From: Thomas Kellerer <spam_eater(at)gmx(dot)net>
To: pgsql-admin(at)postgresql(dot)org
Subject: Re: Getting "ident" to work in Windows
Date: 2012-05-04 13:50:06
Message-ID: jo0mnd$hg0$1@dough.gmane.org (view raw or flat)
Thread:
Lists: pgsql-admin
Magnus Hagander, 04.05.2012 15:22:
>> I'm trying to enable "ident" authentication on my Windows machine using
>> PostgreSQL 9.1
>>
>> However as soon as I add the following line to pg_hba.conf
>>
>>    host    all             all             ::1/128            ident sameuser
>
> "sameuser" was removed in PostgreSQL 8.4. Now you just use "ident" if
> you want that behavior.

Thanks, I somehow missed that.

> It probably told you this in the logfile when you did reload - for
> security reasons, the details of the error are never given to an
> unauthenticated client.

No, I only got the could not load pg_hba.conf" error message.


>> Ideally I would like to make "ident" to work with a custom map but using
>> "ident tkmap". But that throws the same error which isn't really surprising
>> as "ident tkmap" is not working either.
>
> ident map=tkmap
>
> is what you want. See
> http://www.postgresql.org/docs/9.1/static/auth-methods.html#AUTH-IDENT

I still get an authentication error but probably that's because ident is indeed not available on Windows.
It's not that important as I just wanted to play around with it.


Thanks for the help.

Regards
Thomas

  



In response to

pgsql-admin by date

Next:From: Kevin GrittnerDate: 2012-05-04 13:57:08
Subject: Re: Very long "<IDLE> in transaction" query
Previous:From: ktm@rice.eduDate: 2012-05-04 13:38:42
Subject: Re: Very long "<IDLE> in transaction" query

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group