Skip site navigation (1) Skip section navigation (2)

Re: Auto-Vacuum in 8.1 was ineffective for me. 8.2 may work better?

From: Mark Stosberg <mark(at)summersault(dot)com>
To: pgsql-performance(at)postgresql(dot)org
Subject: Re: Auto-Vacuum in 8.1 was ineffective for me. 8.2 may work better?
Date: 2007-02-21 20:28:34
Message-ID: eria2f$2ut7$1@news.hub.org (view raw or flat)
Thread:
Lists: pgsql-performance
Alvaro Herrera wrote:
> Mark Stosberg wrote:
>> When I upgraded a busy database system to PostgreSQL 8.1, I was excited
>> about AutoVacuum, and promptly enabled it, and turned off the daily
>> vacuum process.
>>
>> (
>> I set the following, as well as the option to enable auto vacuuming
>> stats_start_collector = true
>> stats_row_level = true
>> )
>>
>> I could see in the logs that related activity was happening, but within
>> a few days, the performance became horrible, and enabling the regular
>> vacuum fixed it.
>>
>> Eventually autovacuum was completely disabled.
> 
> This has been tracked down to a bug in 8.1's Windows port.  See
> http://people.planetpostgresql.org/mha/index.php?/archives/134-8.1-on-win32-pgstat-and-autovacuum.html

Thanks for the response Alvaro. This would have been on FreeBSD.

Let me ask the question a different way: Is simply setting the two
values plus enabling autovacuuming generally enough, or is further
tweaking common place?

Perhaps I'll give it another tree when we upgrade to 8.2.

  Mark

In response to

Responses

pgsql-performance by date

Next:From: Matthew T. O'ConnorDate: 2007-02-21 20:36:32
Subject: Re: Auto-Vacuum in 8.1 was ineffective for me. 8.2 may work better?
Previous:From: Merlin MoncureDate: 2007-02-21 19:30:50
Subject: Re: General advice on user functions

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group