Skip site navigation (1) Skip section navigation (2)

Re: BUG #5039: 'i' flag i in regexp_replace ignored for polish letters

From: Kamil Roman <kamil(dot)lech(dot)roman(at)gmail(dot)com>
To: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: Robert Haas <robertmhaas(at)gmail(dot)com>, pgsql-bugs(at)postgresql(dot)org
Subject: Re: BUG #5039: 'i' flag i in regexp_replace ignored for polish letters
Date: 2009-10-23 08:13:54
Message-ID: e7a19d920910230113n41b3ced1w446fee3a456ae418@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-bugs
Hello,
yes, I have been using UTF-8. Shouldn't this behaviour be at least
documented in the postgresql documentation? I am aware that it is a bug, but
if it is not likely to be fixed soon IMHO it should be documented somehow.

Regards,
Kamil Roman

2009/10/22 Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>

> Robert Haas <robertmhaas(at)gmail(dot)com> writes:
> > On Sat, Sep 5, 2009 at 5:42 AM, Kamil Roman <kamil(dot)lech(dot)roman(at)gmail(dot)com>
> wrote:
> >> Description:        'i' flag i in regexp_replace ignored for polish
> letters
>
> > I haven't seen a response to this.   Anyone think this might be a bug?
>
> If he's using a multibyte character set (UTF8 most likely) there is
> pretty much 0 hope of it working.  The existing TODO entry for this
> links to
> http://archives.postgresql.org/pgsql-hackers/2008-12/msg00433.php
>
>                        regards, tom lane
>

In response to

pgsql-bugs by date

Next:From: Craig RingerDate: 2009-10-23 11:24:46
Subject: Re: BUG #5130: Failed to run initdb:1
Previous:From: Alvaro HerreraDate: 2009-10-23 01:44:30
Subject: Re: BUG #5021: ts_parse doesn't recognize email addresses with underscores

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group