Skip site navigation (1) Skip section navigation (2)

vacuumdb error

From: Thom Brown <thombrown(at)gmail(dot)com>
To: pgsql-bugs(at)postgresql(dot)org
Subject: vacuumdb error
Date: 2009-10-16 09:55:46
Message-ID: bddc86150910160255m21939084j6655914982229a57@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-bugs
Hi,

I've noticed I can't run vacuumdb with ALL FULL VERBOSE and FREEZE.

The error returned is:

vacuumdb: vacuuming of database "killingcupid.co.uk" failed: ERROR:
syntax error at or near "FREEZE"
LINE 1: VACUUM FULL VERBOSE FREEZE;

The commands I used are:

vacuumdb -afFv
vacuumdb --all --full --freeze --verbose

I've tried moving the switches round to put them in the order
specified in the documentation, just in case it had any effect on the
order of the keywords, but it doesn't.  I can run this manually in
psql using:

VACUUM FULL FREEZE VERBOSE;

This is either a bug in vacuumdb with it not using the correct order,
or postgres shouldn't be paying attention to the order of the
keywords.  In any case, it doesn't work.  I've searched the postgres
FAQs, TODO and mailing list archives, but can't find a mention of
this.

Thanks

Thom

Responses

pgsql-bugs by date

Next:From: Thom BrownDate: 2009-10-16 10:08:50
Subject: Re: vacuumdb error
Previous:From: Dave PageDate: 2009-10-16 09:13:46
Subject: Re: Re: BUG #5065: pg_ctl start fails as administrator, with "could not locate matching postgres executable"

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group