Skip site navigation (1) Skip section navigation (2)

Re: PHP suddenly not recognising pg_connect

From: Thom Brown <thombrown(at)gmail(dot)com>
To: pgsql-php(at)postgresql(dot)org
Subject: Re: PHP suddenly not recognising pg_connect
Date: 2009-10-12 21:03:15
Message-ID: bddc86150910121403q56c9525cu44fa3d43a3f248da@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-php
Okay, ignore me.  It appears that the ini files hadn't been updated,
although looking at the merge, I don't see exactly how that helped.
It's working now anyway.  Postgres and MySQL are both showing in phpinfo()
now.

Thom

2009/10/12 Thom Brown <thombrown(at)gmail(dot)com>

> I restarted apache today and suddenly a site I managed stopped working.  It
> seems php no longer recognises the pg_connect command.  I'm running
> PostgreSQL 8.4.1 and PHP 5.2.11 on Gentoo.  I recompiled PHP just in case
> I'd upgraded PostgreSQL before without recompiling PHP with it, but no luck.
>  I've checked what gentoo says I've got installed, and it says that it used
> postgres as one of the includes with dev-lang/php.
> I've also noticed PHP has also dropped MySQL support.  Doing a phpinfo()
> check, I've got --with-pgsql=shared showing and also mysql=shared,/usr'
> '--with-mysql-sock=/var/run/mysqld/mysqld.sock'
> '--with-mysqli=shared,/usr/bin/mysql_config, but there's no section for
> PostgreSQL on the page, or MySQL.
>
> I installed pgbouncer a couple days ago too, but I don't expect that's got
> anything to do with this.
>
> What's going on?
>
> Thom
>

In response to

pgsql-php by date

Next:From: Thom BrownDate: 2009-10-20 12:02:47
Subject: PostgreSQL driver for Joomla review
Previous:From: Thom BrownDate: 2009-10-12 20:38:15
Subject: PHP suddenly not recognising pg_connect

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group