Skip site navigation (1) Skip section navigation (2)

Can't run psql and other utilities under AIX

From: "Derek M(dot) A(dot) Lee-Wo" <dleewo(at)voicerite(dot)com>
To: pgsql-ports(at)postgresql(dot)org
Subject: Can't run psql and other utilities under AIX
Date: 2002-11-26 14:01:58
Message-ID: arvusk$qu3$1@news.hub.org (view raw or flat)
Thread:
Lists: pgsql-ports
I've installed a precompiled version of PostgreSQL 7.1.2 on AIX and I
managed to get the database up and running.  When I try to run "psql" and
other commands like "createdb", I get the following:

exec(): 0509-036 Cannot load program psql because of the following errors:
        0509-150   Dependent module
/usr/local/lib/libreadline.a(libreadline.so) c
ould not be loaded.
        0509-152   Member libreadline.so is not found in archive

The library libreadline.a and libreadline.so (linked to libreadline.so.4) do
exist in /usr/local/lib. I tried setting LD_LIBRARY_PATH and LIBPATH, but I
get the same problem.

Any suggestions?

Derek



pgsql-ports by date

Next:From: Steffen SchmidtDate: 2002-11-29 10:21:36
Subject: psql version 7.3 can't connect postgres DB version 7.2.3 - using SSH port forwarding
Previous:From: scott.marloweDate: 2002-11-25 23:06:19
Subject: Re: Solaris still failing RC2

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group