Skip site navigation (1) Skip section navigation (2)

problema con la instalacion de postgres desde el yum.pgsqlrpms.org

From: jeison gutierrez <jeisongutierrez(at)gmail(dot)com>
To: pgsql-es-ayuda(at)postgresql(dot)org
Subject: problema con la instalacion de postgres desde el yum.pgsqlrpms.org
Date: 2009-02-17 16:51:41
Message-ID: a0e27d440902170851m7bc5c850j342afaafbcfae88a@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-es-ayuda
Buenos dias,

Tengo CentOS 5.2

removi los paquetes de postgres previamente instalados con yum remove
postgresql*, luego en el fichero /etc/yum.repos.d/CentOS-Base.repo en las
secciones base y updates coloque al comienzo exclude=postgresql*
luego ejecute el comando
wget http://yum.pgsqlrpms.org/reporpms/8.3/pgdg-centos-8.3-5.noarch.rpm
luego
rpm -ivh pgdg-centos-8.3-5.noarch.rpm
luego de esto la salida del comando yum repolist es la siguiente

repo id              repo name                                 status
addons               CentOS-5 - Addons                         enabled
base                 CentOS-5 - Base                           enabled
extras               CentOS-5 - Extras                         enabled
pgdg83               PostgreSQL 8.3 5 - i386                   enabled
updates              CentOS-5 - Updates                        enabled

Hasta aqui todo sin errores

y por ultimo cuando intento el comando yum install postgresql me dice:

--> Running transaction check
--> Processing Dependency: libpq.so.4 for package: perl-DBD-Pg
--> Processing Dependency: libpq.so.4 for package: apr-util
---> Package postgresql-libs.i386 0:8.3.6-1PGDG.rhel5 set to be updated
--> Running transaction check
---> Package perl-DBD-Pg.i386 0:2.9.2-1.rhel5 set to be updated
--> Processing Dependency: perl(version) for package: perl-DBD-Pg
---> Package compat-postgresql-libs.i686 0:4-1PGDG.rhel5 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: perl(version) is needed by package perl-DBD-Pg

ya he actualizado la version de perl y he intentado actualizar la version
del paquete perl-DBD-Pg y me sale el mismo error.

Alguien en el siguiente enlace:

https://projects.commandprompt.com/public/pgcore/ticket/39

parece haber tenido el mismo problema y al parecer fue solucionado pero no
entiendo la solucion,,,,

Por favor si alguno de ustedes me puede colaborar con alguna idea les
agradezco

Hasta pronto.

Responses

pgsql-es-ayuda by date

Next:From: Rodolfo VegasDate: 2009-02-17 17:13:02
Subject: sobre el executor
Previous:From: Alvaro HerreraDate: 2009-02-17 16:45:11
Subject: Re: sobre el executor

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group