Skip site navigation (1) Skip section navigation (2)

Re: PostgreSQL 9.0.2. This is a Bug?

From: Fabricio <fabrixio1(at)hotmail(dot)com>
To: <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: <pgsql-admin(at)postgresql(dot)org>
Subject: Re: PostgreSQL 9.0.2. This is a Bug?
Date: 2011-01-14 22:53:37
Message-ID: SNT139-w3FD290E618C8FFD3ECD80FEF30@phx.gbl (view raw or flat)
Thread:
Lists: pgsql-admin





Linux Slackware 13.1gcc 4.5.1

This .so files works fine in older postgres's versions.Postgres has support for this, but postgres team says do not use it?
thanks tom, regards... 


> To: fabrixio1(at)hotmail(dot)com
> CC: pgsql-admin(at)postgresql(dot)org
> Subject: Re: [ADMIN] PostgreSQL 9.0.2. This is a Bug? 
> Date: Fri, 14 Jan 2011 17:41:31 -0500
> From: tgl(at)sss(dot)pgh(dot)pa(dot)us
> 
> Fabricio <fabrixio1(at)hotmail(dot)com> writes:
> > A developer is writing a function in C code and when he makes some change and replace the old library with the new one and if run CREATE OR REPLACE FUNCTION Postgre crash and restart. After restart CREATE OR REPLACE FUNCTION does not crash postgres, only the first time. He makes a function test.  
> 
> You didn't say what platform this is, but overwriting an actively-used
> .so file isn't a safe thing to do on all systems.  There's nothing
> Postgres can do about that.
> 
> 			regards, tom lane

 		 	   		  

Responses

pgsql-admin by date

Next:From: Tom LaneDate: 2011-01-14 23:06:50
Subject: Re: PostgreSQL 9.0.2. This is a Bug?
Previous:From: Tom LaneDate: 2011-01-14 22:41:31
Subject: Re: PostgreSQL 9.0.2. This is a Bug?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group