Skip site navigation (1) Skip section navigation (2)

DocBook upgrade

From: Peter Eisentraut <peter_e(at)gmx(dot)net>
To: <pgsql-docs(at)postgresql(dot)org>
Subject: DocBook upgrade
Date: 2002-01-18 21:53:13
Message-ID: Pine.LNX.4.30.0201181629150.708-100000@peter.localdomain (view raw or flat)
Thread:
Lists: pgsql-docs
Briefly after we open the floodgates for 7.2+1 I would like to upgrade our
documentation sources to use DocBook 4.1.  There are three reasons for it:

- Some better markup for cases that currently look really ugly.

- The available stylesheets tend to not handle 3.1 correctly in some
  cases.

- We can start exploring XML/XSL-based toolchains.  DocBook XML doesn't
  exist for versions prior to 4.0.

The change will effectively amount to changing the version number at the
very top of the top-level files (book-decl.sgml and postgres.sgml), and
possibly fixing some markup that has been deprecated.

At that time, your processing tools will start complaining that they can't
resolve the public identifier for "-//OASIS//DTD DocBook V4.1//EN" or some
such.  Basically, what you need to do is install the V4.1 DTD in the same
way that 3.1 was installed.  Instructions for this are contained in our
documentation.  I'll be happy to assist if you can't get it to work.

-- 
Peter Eisentraut   peter_e(at)gmx(dot)net


Responses

pgsql-docs by date

Next:From: Thomas LockhartDate: 2002-01-19 03:51:31
Subject: Re: DocBook upgrade
Previous:From: Vince VielhaberDate: 2002-01-18 13:23:50
Subject: Re: Books on PostgreSQL

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group