Skip site navigation (1) Skip section navigation (2)

Error with MSAccess97 subforms and PostODBC

From: Valerio Santinelli <tanis(at)lotus(dot)mediacom(dot)it>
To: pgsql-interfaces(at)postgresql(dot)org
Subject: Error with MSAccess97 subforms and PostODBC
Date: 1999-02-24 16:11:15
Message-ID: Pine.LNX.4.05.9902241706490.13666-100000@lotus.mediacom.it (view raw or flat)
Thread:
Lists: pgsql-interfaces
Here's an extract of a log of the postODBC driver on the machine I'm
running MSAccess 97 on. 

I've got a form with two dependant subforms in it and when I add a new
record, I get two ODBC errors because the two subforms are looking for a
linked field named "IDC" that's currently NULL since it's a new record and
an ID has not yet been assigned. Here's what's happening on my system:

==========

conn=52928376, query='SELECT "Clienti"."id" FROM "login" "Clienti" WHERE (
NULL = "idc" ) '
ERROR from backend during send_query: 'ERROR:  parser: parse error at or
near "="'
STATEMENT ERROR: func=SC_execute, desc='', errnum=1, errmsg='Error while
executing the query'

------------------------------------------------------------
                 hdbc=52928376, stmt=53125516, result=0
                 manual_result=0, prepare=0, internal=0
                 bindings=0, bindings_allocated=0
                 parameters=52928148, parameters_allocated=1
                 statement_type=0, statement='SELECT "Clienti"."id" FROM
"login" "Clienti" WHERE ( ? = "idc" ) '
                 stmt_with_params='SELECT "Clienti"."id" FROM "login"
"Clienti" WHERE ( NULL = "idc" ) '
                 data_at_exec=-1, current_exec_param=-1, put_data=0
                 currTuple=-1, current_col=-1, lobj_fd=-1
                 maxRows=0, rowset_size=1, keyset_size=0, cursor_type=0,
scroll_concurrency=1
                 cursor_name='SQL_CUR032AA18C'
                 ----------------QResult Info
-------------------------------
CONN ERROR: func=SC_execute, desc='', errnum=110, errmsg='ERROR:  parser:
parse error at or near "="'
            ------------------------------------------------------------
            henv=53870724, conn=52928376, status=1, num_stmts=16
            sock=52927816, stmts=52927856, lobj_type=-999
            ---------------- Socket Info -------------------------------
            socket=59, reverse=0, errornumber=0, errormsg='(null)'
            buffer_in=52934704, buffer_out=53104140
            buffer_filled_in=45, buffer_filled_out=0, buffer_read_in=45
conn=52824188, query='SELECT "Clienti"."id" FROM "fatture" "Clienti" WHERE
( NULL = "idc" ) '
ERROR from backend during send_query: 'ERROR:  parser: parse error at or
near "="'
STATEMENT ERROR: func=SC_execute, desc='', errnum=1, errmsg='Error while
executing the query'

------------------------------------------------------------
                 hdbc=52824188, stmt=53036776, result=0
                 manual_result=0, prepare=0, internal=0
                 bindings=0, bindings_allocated=0
                 parameters=52928148, parameters_allocated=1
                 statement_type=0, statement='SELECT "Clienti"."id" FROM
"fatture" "Clienti" WHERE ( ? = "idc" ) '
                 stmt_with_params='SELECT "Clienti"."id" FROM "fatture"
"Clienti" WHERE ( NULL = "idc" ) '
                 data_at_exec=-1, current_exec_param=-1, put_data=0
                 currTuple=-1, current_col=-1, lobj_fd=-1
                 maxRows=0, rowset_size=1, keyset_size=0, cursor_type=0,
scroll_concurrency=1
                 cursor_name='SQL_CUR032946E8'
                 ----------------QResult Info
-------------------------------
CONN ERROR: func=SC_execute, desc='', errnum=110, errmsg='ERROR:  parser:
parse error at or near "="'
            ------------------------------------------------------------
            henv=53870724, conn=52824188, status=1, num_stmts=16
            sock=53870740, stmts=53870780, lobj_type=-999
            ---------------- Socket Info -------------------------------
            socket=50, reverse=0, errornumber=0, errormsg='(null)'
            buffer_in=52830516, buffer_out=52834616
            buffer_filled_in=45, buffer_filled_out=0, buffer_read_in=45



==============

Tabs have got screwed up beacuse I pasted the text from another machine.

Let me know if there's anybody who knows a workaround for this one.

Valerio Santinelli
tanis(at)mediacom(dot)it

P.S.

If you're replying me privately, please do it to tanis(at)mediacom(dot)it
Thanks.



pgsql-interfaces by date

Next:From: Valerio SantinelliDate: 1999-02-24 16:27:55
Subject: Re: [INTERFACES] xmin field in a newly created table.
Previous:From: Michael ZhangDate: 1999-02-24 15:38:42
Subject: Newbie Q: How to deal with date/time with libpq or ecpg?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group