Skip site navigation (1) Skip section navigation (2)

Problem with the perl 5 interface

From: Nathan Pilatzke <nathan(at)info(dot)load-otea(dot)hrdc-drhc(dot)gc(dot)ca>
To: pgsql-interfaces(at)postgresql(dot)org
Subject: Problem with the perl 5 interface
Date: 1999-03-22 17:55:17
Message-ID: Pine.LNX.3.96.990322125438.17749A-100000@info.load-otea.hrdc-drhc.gc.ca (view raw or flat)
Thread:
Lists: pgsql-interfaces
Hello all, I would like some help please, if you can...

We had an older version of PostgreSQL installed on a Debian libc5 system
from source (PostgreSQL 6.3).  We recently upgraded the system to libc6
Debian.  Now I have recompiled the PostgreSQL 6.3 source against libc6
with no apparent problems.  I tried to recompile the
./pgsql/src/interfaces/perl5 module, but it wasn't working until I went in
the Makefile and changed all references to the cc compiler to gcc, then it
compiled and installed with no hitches.  Now none of my perl scripts work
though, all of the cgi scripts return this error in the apache error log:

perl: error in loading shared libraries:
/usr/local/lib/site_perl/i386-linux/auto/Pg/Pg.so: undefined symbol:
safefree

Does anyone know what the problem is here, and more importantly how to
correct it?  Any help is appreciated.

thank you,
nathanp.


"Time is the best teacher; Unfortunately it kills all it's students!"



pgsql-interfaces by date

Next:From: James ThompsonDate: 1999-03-22 17:56:58
Subject: Re: [INTERFACES] Installation of postgresql 6.4.2 + libpq
Previous:From: Nathan PilatzkeDate: 1999-03-22 17:49:42
Subject: Problem with the perl 5 interface

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group