Skip site navigation (1) Skip section navigation (2)

Re: gcj has a lot of complaints about 8.1-405 release

From: Kris Jurka <books(at)ejurka(dot)com>
To: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: Dave Cramer <pg(at)fastcrypt(dot)com>, pgsql-jdbc(at)postgreSQL(dot)org
Subject: Re: gcj has a lot of complaints about 8.1-405 release
Date: 2006-03-27 23:24:39
Message-ID: Pine.BSO.4.63.0603271756001.21311@leary.csoft.net (view raw or flat)
Thread:
Lists: pgsql-jdbc

On Mon, 27 Mar 2006, Tom Lane wrote:

> Apache Ant version 1.6.5 compiled on March 6 2006
> Detected Java version: 1.5 in: /usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre
>
> If the java package version means what I think it means, then this is
> misdetecting the version.  Is this our fault, or is something screwy
> in Red Hat's build environment?
>

Your version of ant determines it is a 1.5 JVM by being able to load the 
java.lang.Readable interface which shouldn't exist in a 1.4 JVM.  Newer 
versions of ant (2 days old) check for java.net.Proxy instead.

http://issues.apache.org/bugzilla/show_bug.cgi?id=39027

Kris Jurka

In response to

Responses

pgsql-jdbc by date

Next:From: Dave CramerDate: 2006-03-27 23:30:25
Subject: Re: gcj has a lot of complaints about 8.1-405 release
Previous:From: Tom LaneDate: 2006-03-27 23:18:07
Subject: Re: gcj has a lot of complaints about 8.1-405 release

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group