Skip site navigation (1) Skip section navigation (2)

Re: ALTER EXTENSION UPGRADE, v3

From: "David E(dot) Wheeler" <david(at)kineticode(dot)com>
To: Aidan Van Dyk <aidan(at)highrise(dot)ca>
Cc: Dimitri Fontaine <dimitri(at)2ndquadrant(dot)fr>, Itagaki Takahiro <itagaki(dot)takahiro(at)gmail(dot)com>, PostgreSQL Hackers <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: ALTER EXTENSION UPGRADE, v3
Date: 2011-02-02 18:28:33
Message-ID: FCB817D9-61EF-4CE2-B7FB-17741F266C87@kineticode.com (view raw or flat)
Thread:
Lists: pgsql-hackers
On Feb 2, 2011, at 10:14 AM, Aidan Van Dyk wrote:

> My concern with this approach (upgrade is forced through all
> intermetiary versions) is that the shared libray now for version 15
> *has* to have all the "intermediary" compatibility for *all* versions
> in it.  So it has to have functions with all symbols so the "CREATE
> ..." staements for all previous 15 versions can succeed.
> 
> With having the $old -> $new scripts, the new .so only needs to have
> functions enough that the DROPs work, and the new CREATE... work.

Yeah, so that's another argument for some sort of include syntax, instead, so the upgrade scripts can include other scripts as appropriate.

Best,

David


In response to

Responses

pgsql-hackers by date

Next:From: David E. WheelerDate: 2011-02-02 18:29:28
Subject: Re: ALTER EXTENSION UPGRADE, v3
Previous:From: Dimitri FontaineDate: 2011-02-02 18:22:33
Subject: Re: ALTER EXTENSION UPGRADE, v3

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group