Skip site navigation (1) Skip section navigation (2)

Re: [Tigerlead] BUG #5334: Version 2.22 of Perl Safe module breaks UTF8 PostgreSQL 8.4

From: "David E(dot) Wheeler" <david(dot)wheeler(at)pgexperts(dot)com>
To: Tim Bunce <Tim(dot)Bunce(at)pobox(dot)com>
Cc: pgsql-bugs(at)postgresql(dot)org
Subject: Re: [Tigerlead] BUG #5334: Version 2.22 of Perl Safe module breaks UTF8 PostgreSQL 8.4
Date: 2010-02-18 21:36:59
Message-ID: F0B5E2EB-7DEC-41CE-8E0C-7855554D62C2@pgexperts.com (view raw or flat)
Thread:
Lists: pgsql-bugs
On Feb 18, 2010, at 10:09 AM, Tim Bunce wrote:

> It took a depressingly large number of intense hours to work out what
> was going on and then more to try to work out a relatively clean solution.
> 
> The underlying problem is in perl and Safe but sadly there's no
> reasonable way to fix Safe such that PostgreSQL would work without
> changes.

Hrm. I don't have this bug with Safe 3.19, FWIW.

Best,

David

In response to

Responses

pgsql-bugs by date

Next:From: Bruce MomjianDate: 2010-02-19 01:17:08
Subject: Re: BUG #5250: Tutorial examples(pre-compiled) not present with precompiled binary version of PostgreSQL.
Previous:From: Alex HunsakerDate: 2010-02-18 18:32:38
Subject: Re: BUG #5334: Version 2.22 of Perl Safe module breaks UTF8 PostgreSQL 8.4

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group