Skip site navigation (1) Skip section navigation (2)

Re: ALTER EXTENSION UPGRADE, v3

From: "David E(dot) Wheeler" <david(at)kineticode(dot)com>
To: Dimitri Fontaine <dimitri(at)2ndQuadrant(dot)fr>
Cc: Itagaki Takahiro <itagaki(dot)takahiro(at)gmail(dot)com>, PostgreSQL Hackers <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: ALTER EXTENSION UPGRADE, v3
Date: 2011-02-02 17:09:59
Message-ID: EC2504AE-D0F7-44DE-B4F4-DF8B8D156673@kineticode.com (view raw or flat)
Thread:
Lists: pgsql-hackers
On Feb 2, 2011, at 9:03 AM, Dimitri Fontaine wrote:

> Well, fair enough I suppose.  Or it would be if you gave me an
> alternative that provides a simpler way to support those 3 upgrades.

I did: a naming convention with upgrade scripts that have the version number in them. You rejected it.

> Of course if that's too much for you, you can also choose to only
> support upgrades one versions at a time and provide only two scripts.
> Note also that I don't recall of any proposal on the table that would
> help with that situation, so I'm all ears.

http://archives.postgresql.org/pgsql-hackers/2011-01/msg00296.php

Best,

David



In response to

Responses

pgsql-hackers by date

Next:From: Andrew DunstanDate: 2011-02-02 17:10:59
Subject: Re: Optimize PL/Perl function argument passing [PATCH]
Previous:From: Dimitri FontaineDate: 2011-02-02 17:03:07
Subject: Re: ALTER EXTENSION UPGRADE, v3

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group