On Jun 17, 2010, at 2:56 , David E. Wheeler wrote:
> On Jun 16, 2010, at 4:58 PM, Tom Lane wrote:
>>> hstore => text is new in 9.0.
>> Wup, sorry, I read this as being the other operator. Nevermind ...
>> (FWIW, I share your dislike of & for this operator. I just haven't
>> got a better idea.)
> There aren't any very good choices.
Since there seems to be no consensus on this, maybe thats a sign that there shouldn't be an operator for this at all. I suggested & due due the similarities to ?&, but I can see why people object to that - mainly because it looks like an predicate, not like an operation on hstores.
How about turning it into a function
hstore hstore(hstore, text)
Could also be hstore_restrict if people think naming it just hstore is ambiguous.
In response to
pgsql-hackers by date
|Next:||From: Josh Berkus||Date: 2010-06-17 20:39:32|
|Subject: Re: hstore ==> and deprecate =>|
|Previous:||From: Greg Smith||Date: 2010-06-17 19:43:58|
|Subject: Re: ANNOUNCE list (was Re: New PGXN Extension site)|