Skip site navigation (1) Skip section navigation (2)

Re: Installing postgres on win XP

From: "Dave Page" <dpage(at)vale-housing(dot)co(dot)uk>
To: "Bruce Momjian" <pgman(at)candle(dot)pha(dot)pa(dot)us>
Cc: <pgsql-hackers-win32(at)postgresql(dot)org>
Subject: Re: Installing postgres on win XP
Date: 2005-08-11 14:24:34
Message-ID: E7F85A1B5FF8D44C8A1AF6885BC9A0E4AC998E@ratbert.vale-housing.co.uk (view raw or flat)
Thread:
Lists: pgsql-hackers-win32
 

> -----Original Message-----
> From: Bruce Momjian [mailto:pgman(at)candle(dot)pha(dot)pa(dot)us] 
> Sent: 11 August 2005 15:17
> To: Dave Page
> Cc: pgsql-hackers-win32(at)postgresql(dot)org
> Subject: Re: [pgsql-hackers-win32] Installing postgres on win XP
> 
> Dave Page wrote:
> > > The plain PostgreSQL-8.0, if run, says "The installation 
> package could
> > > not be opened.  Verify that the package ...".  If I click on the
> > > PostgreSQL-8.0-int, the installer works.  This is a fresh 
> download run
> > > from my desktop.
> > > 
> > > This is on XP Pro.  
> > 
> > Sounds like it's already installed on your machine. If that 
> is the case,
> > you can directly run the -int msi and it'll go into 
> maintenance mode,
> > using the language option setup by the bootstrapper on the first
> > invocation. On a clean machine, you cannot run the -int msi 
> - it'll fail
> > with an appropriate message telling you what to do.
> 
> OK, I uninstalled, and tried again.  Now, for the non-int file (the
> first one), I get the language selection window, but once 
> choose Next, I
> get the same error message listed above about not being opened.  If I
> click on the *-int file, I do get a suggestion to run the MSI file.

Yea, that's the expected behaviour (and is the same as Winzip). Unpack,
then run is the only safe way. Unfortunately, we cannot combine the two
files together without losing the multi-language support. It took a lot
of hoop jumping to get it to the point it is now, and it still won't
work in Japanese :-( (hence why we distribute a different copy for
Japanese users).

Regards, Dave

pgsql-hackers-win32 by date

Next:From: Bruce MomjianDate: 2005-08-12 21:23:24
Subject: Re: patch for win32 dynloader
Previous:From: Bruce MomjianDate: 2005-08-11 14:17:15
Subject: Re: Installing postgres on win XP

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group