Skip site navigation (1) Skip section navigation (2)

Re: new wx lib needed

From: "Dave Page" <dpage(at)vale-housing(dot)co(dot)uk>
To: "Andreas Pflug" <pgadmin(at)pse-consulting(dot)de>,<pgadmin-hackers(at)postgresql(dot)org>
Subject: Re: new wx lib needed
Date: 2005-02-28 20:49:19
Message-ID: E7F85A1B5FF8D44C8A1AF6885BC9A0E472B804@ratbert.vale-housing.co.uk (view raw or flat)
Thread:
Lists: pgadmin-hackers
 

> -----Original Message-----
> From: Andreas Pflug [mailto:pgadmin(at)pse-consulting(dot)de] 
> Sent: 28 February 2005 17:38
> To: Dave Page; pgadmin-hackers(at)postgresql(dot)org
> Subject: Re: new wx lib needed
> 
> Hi Dave,
> apparently you're quite busy coding pgAgent.

Yeah, well, trying to figure it all out anyway! All the OID related code
should be gone now, and I can create jobs and steps in pga quite
happily. There are issues with the browser though, as well as the
schedule dialogue stuff to do. I do have a couple of questions though -
I'll bung those in another email.

> I'm not too lazy too, and to commit my work there are some 
> prerequisites.

:-)

> Apparently, the mail I've sent yesterday about a required lib 
> didn't go 
> into the list, what's wrong?
> 

The hub.org servers were rehomed onto a bgp routed network yesterday -
at a vaguely informed guess, some of the list traffic failed to get
delivered immediately, and went into exponential backoff. Net result is
that some emails got quite delayed.

> 
> Andreas Pflug wrote:
> > Hi friends,
> > 
> > quite soon pgAdmin will need the OGL contrib package to link. It 
> > provides graphics for "objects connected by lines". It will 
> be used to 
> > implement a graphical explain.

Oh, ok. That was third on my current list, after pgAgent and the query
builder rewrite (which apparently our Japanese users *really* want to
see).

> > Currently, the OGL lib will need the additional 
> "deprecated" package, 
> > which we don't need at all. To avoid that, OGL should be 
> compiled with 
> > wxUSE_DEPRECATED=0, because this value defaults to 1 if not 
> set. I'll 
> > post to wx-dev to have this flag changed, maybe I succeed.

OK, no problem.

BTW: I assume you saw my recent commit to use the libs from the
pgInstaller distro now? The Windows build enviroment is pretty
straightforward now :-)

Regards, Dave.

pgadmin-hackers by date

Next:From: cvsDate: 2005-02-28 23:14:13
Subject: CVS Commit by dpage: Further pgAgent updates.
Previous:From: Andreas PflugDate: 2005-02-28 17:38:03
Subject: Re: new wx lib needed

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group