Skip site navigation (1) Skip section navigation (2)

RE: ODBC Problem

From: "Henshall, Stuart - WCP" <SHenshall(at)westcountrypublications(dot)co(dot)uk>
To: "'Jamz(at)AirNet(dot)Com(dot)AU'" <Jamz(at)AirNet(dot)Com(dot)AU>, pgsql-interfaces(at)postgresql(dot)org
Subject: RE: ODBC Problem
Date: 2001-07-18 08:58:17
Message-ID: E2870D8CE1CCD311BAF50008C71EDE8E01F7461B@MAIL_EXCHANGE (view raw or flat)
Thread:
Lists: pgsql-interfaces
It may well be worth trying the latest version of the driver (Have a look at
http://odbc.postgresql.org , or
http://www.ca.postgresql.org/ftpsite/odbc/versions/full/)
Also there is an postgreSQL ODBC specific list: pgsql-odbc(at)postgresql(dot)org
- Stuart

> -----Original Message-----
> From:	Jamz(at)AirNet(dot)Com(dot)AU [SMTP:Jamz(at)AirNet(dot)Com(dot)AU]
> Sent:	Wednesday, July 18, 2001 1:11 AM
> To:	pgsql-interfaces(at)postgresql(dot)org
> Subject:	ODBC Problem
> 
> Greetings people,
>             Before I go nuts, I wonder if anyone has solved this problem
> before; I have been using the ODBC driver for our Postgres server to
> develop software in Visual Basic with great success until just recently.
>  
> Symptoms of the problem are that queries on some machines execute
> correctly, but taking the same code and executing it on another machine
> returns empty recordsets.  I made sure all the drivers were the same and
> that the latest MDAC 2.7 was installed on all machines.
>  
> On further investigation, I found that on the affected machines, queries
> to tables with an index come back with an empty recordset.
>  
> Win2k Terminal Server SP2: okay - queries return data
> WinXP Beta2: okay - queries return data
> WinNT4 Server: only queries on some tables return data
> Win2k Server SP2: only queries on some tables return data
>  
> I guess this must be something to do with the setup of the ODBC driver on
> these machines, but I can't for the life of me find any difference in
> settings.  All the machines use identical connect strings.
>  
> I looked at the ODBC logs to find something that was failing and couldn't
> really see any thing bad:
>  
> conn=35795448,
> SQLDriverConnect(out)='DRIVER={PostGreSQL};DATABASE=bmf;SERVER=bm
> f.some.domain;PORT=5432;UID=postgres;PWD=xxxxx;READONLY=0;PROTOCOL=6.4;FA
> KEOIDINDEX=0;SHOWOIDCOLUMN=0;ROWVERSIONING=0;SHOWSYSTEMTABLES=0;CONNSETTIN
> GS='
> conn=35795448, query='SELECT * FROM userservices WHERE printform=true AND
> formpr
> inted IS NULL'
>     [ fetched 1 rows ]
> conn=35795448, SQLDisconnect
>  
> So it looked like the row I wanted was retrieved but the recordset still
> remained empty :-(
>  
> I believe the server is running Postgres 7.0.3 :
>  
> [root(at)bmf bin]# ./psql -V
> psql (PostgreSQL) 7.0.3
> contains readline, history support
> Portions Copyright (c) 1996-2000, PostgreSQL, Inc
> Portions Copyright (c) 1996 Regents of the University of California
> Read the file COPYRIGHT or use the command \copyright to see the
> usage and distribution terms.
>  
> All machines are using the same ODBC driver version 6.5, PSQLODBC.DLL
> 4/2/2000
>  
> If anyone knows if there is a known problem with this combo please let me
> know and I will have a case to get the admin to upgrade.
>  
> Cheers & TIA,
>             Jamz.
>  
>  
>  
> =-=-=-=-=-=-=-=-=-=-=-=-
> "We should have laser guns!"
>       - Andrew Hill (Post Support Call)
>  

Responses

pgsql-interfaces by date

Next:From: Henshall, Stuart - WCPDate: 2001-07-18 09:09:07
Subject: RE: MS Access 97 SR-1, psqlodbc 7.01.00.06, slow perfomance
Previous:From: pgsql-bugsDate: 2001-07-18 08:18:23
Subject: libpgtcl doesn't use UTF encoding of TCL

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group