Skip site navigation (1) Skip section navigation (2)

BUG #7545: Unresponsive server with error log reporting: "poll()failed: Invalid argument"

From: tanakalen(at)gmail(dot)com
To: pgsql-bugs(at)postgresql(dot)org
Subject: BUG #7545: Unresponsive server with error log reporting: "poll()failed: Invalid argument"
Date: 2012-09-17 09:00:05
Message-ID: E1TDXBV-0002h4-GU@wrigleys.postgresql.org (view raw or flat)
Thread:
Lists: pgsql-bugs
The following bug has been logged on the website:

Bug reference:      7545
Logged by:          Len Tanaka
Email address:      tanakalen(at)gmail(dot)com
PostgreSQL version: 9.2.0
Operating system:   Mac OS X 10.6.8
Description:        

Multiple log files with same error repeated:
poll() failed: Invalid argument

Prior to error, in user account in user table doing an insert that has not
failed in past. Unresponsive thereafter. Unable to shutdown postmaster.

configure:
./configure --with-includes=/sw/include --with-libraries=/sw/lib --with-perl
--with-python --with-openssl --with-bonjour --with-pam --with-krb5
--with-ldap --enable-thread-safety --with-libxml --with-libxslt
--enable-dtrace

make check passed all tests.

Thanks for any help, reverted to 9.1.5 and no similar problem.

Len



Responses

pgsql-bugs by date

Next:From: stuartDate: 2012-09-17 10:28:49
Subject: BUG #7546: Backups on hot standby cancelled despite hot_standby=on
Previous:From: Amit KapilaDate: 2012-09-17 07:03:28
Subject: Re: [BUGS] BUG #7534: walreceiver takes long time to detect n/w breakdown

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group