Skip site navigation (1) Skip section navigation (2)

pgsql: psql: Reduce compatibility warning

From: Peter Eisentraut <peter_e(at)gmx(dot)net>
To: pgsql-committers(at)postgresql(dot)org
Subject: pgsql: psql: Reduce compatibility warning
Date: 2012-09-01 03:29:30
Message-ID: E1T7eOo-0001ib-Mn@gemulon.postgresql.org (view raw or flat)
Thread:
Lists: pgsql-committers
psql: Reduce compatibility warning

Only warn when connecting to a newer server, since connecting to older
servers works pretty well nowadays.  Also update the documentation a
little about current psql/server compatibility expectations.

Branch
------
master

Details
-------
http://git.postgresql.org/pg/commitdiff/5cad02452457d7f6f29404411dfe13e6fe8accb7

Modified Files
--------------
doc/src/sgml/ref/psql-ref.sgml |   26 ++++++++++++++++++--------
src/bin/psql/command.c         |    4 ++--
2 files changed, 20 insertions(+), 10 deletions(-)

pgsql-committers by date

Next:From: Tom LaneDate: 2012-09-01 04:40:35
Subject: pgsql: More documentation updates for LATERAL.
Previous:From: Andrew DunstanDate: 2012-09-01 00:51:27
Subject: pgsql: Restore setting of _USE_32BIT_TIME_T to 32 bit MSVC builds.

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group