Skip site navigation (1) Skip section navigation (2)

pgsql: In pg_upgrade,disallow migration of 8.3 clusters using contrib/

From: Bruce Momjian <bruce(at)momjian(dot)us>
To: pgsql-committers(at)postgresql(dot)org
Subject: pgsql: In pg_upgrade,disallow migration of 8.3 clusters using contrib/
Date: 2011-09-07 18:43:17
Message-ID: E1R1N5h-00068L-AG@gemulon.postgresql.org (view raw or flat)
Thread:
Lists: pgsql-committers
In pg_upgrade, disallow migration of 8.3 clusters using contrib/ltree
because its internal format was changed in 8.4.

Backpatch to 9.0 and 9.1.

Report by depesz, diagnosis by Tom.

Branch
------
REL9_1_STABLE

Details
-------
http://git.postgresql.org/pg/commitdiff/8cdd62068d2b6913902741f2fbc74d51042c3d3e

Modified Files
--------------
contrib/pg_upgrade/check.c           |    1 +
contrib/pg_upgrade/pg_upgrade.h      |    1 +
contrib/pg_upgrade/version_old_8_3.c |   81 ++++++++++++++++++++++++++++++++++
doc/src/sgml/pgupgrade.sgml          |    5 ++
4 files changed, 88 insertions(+), 0 deletions(-)

pgsql-committers by date

Next:From: Bruce MomjianDate: 2011-09-07 19:44:23
Subject: pgsql: Allow bcc32 and win32 batch files to compile libpq.
Previous:From: Tom LaneDate: 2011-09-07 17:29:48
Subject: pgsql: Fix typo in error message.

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group