Skip site navigation (1) Skip section navigation (2)

Mostrar imágen desde campo bytea

From: Guillermo Villanueva <guillermovil(at)gmail(dot)com>
To: pgsql-es-ayuda <pgsql-es-ayuda(at)postgresql(dot)org>
Subject: Mostrar imágen desde campo bytea
Date: 2012-06-15 16:18:45
Message-ID: CANm+PCC5xq6pVF6De8bhmEYDmNuPyW_GPP0AL84bVZMdqp1VvA@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-es-ayuda
Amigos, sguí avanzando un poco con el problema que por si no lo leyeron
antes se los vuelvo a contar.
En un ubuntu server y en windows tengo un php que muestra una imágen desde
un campo bytea. Este php funciona correctamente en ambos servidores y la
foto aparece en el navegador.
Cuando paso todo el sistema al servidor del hosting, todo funciona bien
menos esto, el de la imágen..
Hice una prueba con la función  pg_unescape_bytea() para poder detectar
porque en un sitio anda y en otro no.
Hago un var_dump de lo que devuelve la función pg_unescape_bytea() y para
la misma imágen, me doy con que las cadenas son diferentes.
En ambos tengo postgres server 9.1 instalado .
En centos (el q no muestra la imágen) tengo PostgreSQL(libpq) Version
8.1.23
En win y ubuntu tengo PostgreSQL(libpq) Version 8.3.6

Tienen idea de que puede estar pasando? Ojalá que si, porque yo ya no se
que mas probar.

Responses

pgsql-es-ayuda by date

Next:From: Ernesto VerbanazDate: 2012-06-15 16:32:04
Subject: Re: Mostrar imágen desde campo bytea
Previous:From: Guillermo VillanuevaDate: 2012-06-15 04:34:11
Subject: Re: [pgsql-es-ayuda] postgres + php + versión

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group