Skip site navigation (1) Skip section navigation (2)

Re: Problem with pg_upgrade

From: Payal Singh <payals1(at)umbc(dot)edu>
To: Craig Ringer <ringerc(at)ringerc(dot)id(dot)au>
Cc: pgsql-bugs(at)postgresql(dot)org
Subject: Re: Problem with pg_upgrade
Date: 2012-07-05 20:24:28
Message-ID: (view raw or whole thread)
Lists: pgsql-bugs
Thank you. That worked.


On Thu, Jul 5, 2012 at 12:15 PM, Craig Ringer <ringerc(at)ringerc(dot)id(dot)au> wrote:

>  On 07/05/2012 11:20 PM, Payal Singh wrote:
> Hello,
>  I am trying to use pg_upgrade to upgrade data from 9.1.4 to 9.2beta2.
> Although the upgrade completed successfully,  vacuumdb --all --analyze-only
> gives an error. I tried upgrading two binary backups of the same production
> database from different days, and both returned the exact same error . The
> output I got for both trials is as follows:
> Just out of interest, if you try to use pg_ctl to start a 9.1 server from
> those backups, do they work? Can they be vaccuumed then?
> If you start 9.1 on a copy of the backup then cleanly stop it again, does
> pg_upgrade then run?
> --
> Craig Ringer

Payal Singh
Graduate Student
Department of Computer Science and Electrical Engineering
University of Maryland, Baltimore County

In response to


pgsql-bugs by date

Next:From: Tom LaneDate: 2012-07-05 22:28:31
Subject: Re: Problem with pg_upgrade
Previous:From: Tom LaneDate: 2012-07-05 20:10:37
Subject: Re: BUG #6715: 9.2b2 psql \ir does not understand leading ../

Privacy Policy | About PostgreSQL
Copyright © 1996-2015 The PostgreSQL Global Development Group