Skip site navigation (1) Skip section navigation (2)

Debug PostgreSQL function using pgAdmin

From: Ken Chan <kenchanmc(at)gmail(dot)com>
To: pgadmin-support-request(at)postgresql(dot)org, pgadmin-support(at)postgresql(dot)org
Subject: Debug PostgreSQL function using pgAdmin
Date: 2011-10-23 17:42:48
Message-ID: CAG=y6ZnzzTPAot==4CjPbxi7BJ-ivS4iX9nX7epKOpVQAUnwFg@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-support
I refer this (
http://www.postgresonline.com/journal/archives/214-Using-PgAdmin-PLPgSQL-Debugger.html)
 to enable the debugger in the PostgreSQL server in order to debugging the
plpgsql function by stepping through the codes using the pgadmin.

I have already set shared_preload_libraries =
'$libdir/plugins/plugin_debugger.dll' in the postgresql.conf, run
pldbgapi.sql , and restarted the server.

These steps should have been run successfully and plugin_debugger.dll should
be loaded successfully as can be verified by using the command show
shared_preload_libraries, and I can see the debugging option in the context
menu with a right click on a function in pgAdmin.

When choosing "Debugging" --> Debug, a window pops up to allow me to enter
the values for the input parameters. But after that, when I press OK, it
does not respond at all.

Any ideas or did I miss something in the setup of the debugger on the
server??

I am using PostgreSQL 8.3  on window XP and pgAdmin 1.14.

For more information including the screen captures , please refer to my
questions at

http://stackoverflow.com/questions/7865615/debug-postgresql-function-using-pgadmin

Thanks and best regards,
Ken

Responses

pgadmin-support by date

Next:From: sito-itoDate: 2011-10-24 08:34:34
Subject: Re: Query tool not open
Previous:From: Guillaume LelargeDate: 2011-10-22 20:55:39
Subject: Re: Debs

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group