2012/7/13 Shigeru HANADA <shigeru(dot)hanada(at)gmail(dot)com>:
> (2012/07/12 20:48), Kohei KaiGai wrote:
>> It seems to me what postgresql_fdw_validator() is doing looks like
>> a function to be named as "libpq_fdw_validator()".
>> How about your opinion? It will help this namespace conflicts.
> I'd prefer dblink_fdw_validator.
> The name "libpq_fdw_validator" impresses me that a concrete FDW named
> "libpq_fdw" is somewhere and it retrieves external data *from* libpq.
> Indeed postgresql_fdw_validator allows only some of libpq options at the
> moment, but we won't be able to rename it for backward compatibility
> even if it wants to have non-libpq options in the future.
> IMO basically each FDW validator should be owned by a particular FDW,
> because in most cases validator should know FDW's internal deeply. In
> addition, it would want to have new options for new features.
> Besides naming, as mentioned upthread, removing hard-coded libpq options
> list from dblink and leaving it to libpq client library would make
> dblink more robust about libpq option changes in future.
OK, it seems to me fair enough.
Does someone have different opinions?
KaiGai Kohei <kaigai(at)kaigai(dot)gr(dot)jp>
In response to
pgsql-hackers by date
|Next:||From: Etsuro Fujita||Date: 2012-07-13 03:35:12|
|Subject: Re: pgsql_fdw in contrib|
|Previous:||From: Tom Lane||Date: 2012-07-13 02:52:14|
|Subject: Re: has_language_privilege returns incorrect answer for non-superuser|