Skip site navigation (1) Skip section navigation (2)

Re: fairly useless psql compatibility warning?

From: Magnus Hagander <magnus(at)hagander(dot)net>
To: Peter Eisentraut <peter_e(at)gmx(dot)net>
Cc: pgsql-hackers(at)postgresql(dot)org
Subject: Re: fairly useless psql compatibility warning?
Date: 2012-08-31 08:59:47
Message-ID: CABUevEw81xtBByRoCqe290iFQF+njrC9xfoM7FZOXobBWvaeRg@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-hackers
On Fri, Aug 31, 2012 at 4:07 AM, Peter Eisentraut <peter_e(at)gmx(dot)net> wrote:
> psql has supported older servers for a great while now, so this sort of
> things seems pretty useless now:
>
> psql (9.2rc1, server 9.1.4)
> WARNING: psql version 9.2, server version 9.1.
> Some psql features might not work
>
> I think it should be reduced to warning when connected to a newer
> server.

Seems like a good idea to me. +1. (Obviously keeping the first line
that shows that the version numbers are different, but not WARNING)

-- 
 Magnus Hagander
 Me: http://www.hagander.net/
 Work: http://www.redpill-linpro.com/


In response to

Responses

pgsql-hackers by date

Next:From: Dimitri FontaineDate: 2012-08-31 10:05:48
Subject: Re: Event Triggers reduced, v1
Previous:From: Kohei KaiGaiDate: 2012-08-31 08:09:24
Subject: Re: [v9.3] Extra Daemons (Re: elegant and effective way for running jobs inside a database)

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group