Skip site navigation (1) Skip section navigation (2)

PostgreSQL 9 with Pacemaker/DRBD

From: Danny Ferrin <ferrin(dot)danny(at)gmail(dot)com>
To: pgsql-cluster-hackers(at)postgresql(dot)org
Subject: PostgreSQL 9 with Pacemaker/DRBD
Date: 2011-08-13 18:45:24
Message-ID: CAAjqEArczmy5tkL6+gVyizaWPfpisCB4Dc7xRzK7MFjSwAGw8Q@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-cluster-hackers
Hi all,

I'm currently trying to set up a master/slave cluster with PostgreSQL 9 and
DRBD.

On my Ubuntu 10.04 nodes, I've installed Heartbeat 3.0.3 and Pacemaker 1.08
and DRBD 8.3.7.

I also installed PostgreSQL 9 via this backport repo: ppa:pitti/postgresql

The pacemaker/heartbeat cluster is working with DRBD except for one thing,
the ocf:heartbeat:pgsql resource agent seems to be outdated for PostgreSQL
9.

I've changed the installation paths in the  pgsql resource agent to be in
line with my backport repo installation.

Anyone had success with DRBD + PostgreSQL 9.

If not, what do you suggest for the replication? I need HA first and
foremost.

Thanks!

Danny

pgsql-cluster-hackers by date

Next:From: Fabricio MotaDate: 2011-09-03 17:40:05
Subject: Hi all!
Previous:From: spinlockDate: 2011-05-25 22:34:37
Subject:

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group