Skip site navigation (1) Skip section navigation (2)

Re: BUG #6367: Missing pg_config

From: Robert Haas <robertmhaas(at)gmail(dot)com>
To: thangalin(at)gmail(dot)com
Cc: pgsql-bugs(at)postgresql(dot)org
Subject: Re: BUG #6367: Missing pg_config
Date: 2012-01-09 18:07:44
Message-ID: CA+TgmoZep8DdAXGMy50QqOTxoSQKA9VfnZ8iROwZQrm7z2aOqA@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-bugs
On Fri, Dec 30, 2011 at 9:17 AM,  <thangalin(at)gmail(dot)com> wrote:
> The following bug has been logged on the website:
>
> Bug reference:      6367
> Logged by:          D J
> Email address:      thangalin(at)gmail(dot)com
> PostgreSQL version: 9.1.2
> Operating system:   Kubuntu Linux 10.10
> Description:
>
> REPLICATE
> 1. Clean OS.
> 2. Use "synaptic" to install postgresql-8.4 packages.
> 3. Install a database into /home/postgres/8.4/main
> 4. Add PPA for pitti.
> 5. Use "synaptic" to upgrade postgres-8.4 packages to postgresql-9.1.
> 6. Stop both the databases (/etc/init.d/postgresql stop).
> 7. Run pg_upgrade:
>
> /usr/lib/postgresql/9.1/bin/pg_upgrade --link
> --old-datadir=/home/postgres/8.4/main --new-datadir=/home/postgres/9.1/main
> --old-bindir=/usr/lib/postgresql/8.4/bin
> --new-bindir=/usr/lib/postgresql/9.1/bin
>
> EXPECTED RESULTS
> The 8.4 database is upgraded to 9.1 using a hard link.
>
> ACTUAL RESULTS
> check for /usr/lib/postgresql/9.1/bin/pg_config failed - No such file or
> directory
>
> SYSTEM DETAILS
> $ locate pg_config
> /usr/bin/pg_config
> /usr/include/postgresql/pg_config.h
> /usr/include/postgresql/pg_config_manual.h
> /usr/include/postgresql/pg_config_os.h
> /usr/include/postgresql/8.4/server/pg_config.h
> /usr/include/postgresql/8.4/server/pg_config_manual.h
> /usr/include/postgresql/8.4/server/pg_config_os.h
> /usr/lib/postgresql/8.4/bin/pg_config
> /usr/share/locale-langpack/en_GB/LC_MESSAGES/pg_config-8.4.mo
> /usr/share/man/man1/pg_config.1.gz
> /usr/share/postgresql/8.4/man/man1/pg_config.1
> /usr/share/postgresql-common/t/140_pg_config.t
>
> $ uname -a
> Linux jaguar 2.6.35-30-generic #54-Ubuntu SMP Tue Jun 7 18:41:54 UTC 2011
> x86_64 GNU/Linux
>
> $ psql --version
> psql (PostgreSQL) 8.4.9
>
> $ which psql
> /usr/bin/psql
>
> $ /usr/lib/postgresql/8.4/bin/psql --version
> psql (PostgreSQL) 8.4.9
>
> $ /usr/lib/postgresql/9.1/bin/psql --version
> psql (PostgreSQL) 9.1.2
> contains support for command-line editing
>
> ADDITIONAL INFORMATION
> It also appears as though the header files are not cleanly installed. It
> looks like the 8.4 header files do not use symbolic links.

I think you will need to report this to the Ubuntu folks.

-- 
Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

In response to

pgsql-bugs by date

Next:From: Robert HaasDate: 2012-01-09 18:16:37
Subject: Re: BUG #6371: Installation process
Previous:From: Robert HaasDate: 2012-01-09 18:03:45
Subject: Re: BUG #6364: The URL for the page listing user groups is unresponsive.

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group