Skip site navigation (1) Skip section navigation (2)

Re: BUG #6121: error msg feature request for initial server tasks

From: Robert Haas <robertmhaas(at)gmail(dot)com>
To: Thomas Pitschel <Th(dot)Pitschel(at)web(dot)de>
Cc: pgsql-bugs(at)postgresql(dot)org
Subject: Re: BUG #6121: error msg feature request for initial server tasks
Date: 2011-07-20 19:03:40
Message-ID: CA+TgmoYeznpSDRQ9ofmkLpKynLEyAUNEKCSiv98fmWpXhYCrWw@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-bugs
On Sun, Jul 17, 2011 at 8:17 AM, Thomas Pitschel <Th(dot)Pitschel(at)web(dot)de> wrote:
>
> The following bug has been logged online:
>
> Bug reference:      6121
> Logged by:          Thomas Pitschel
> Email address:      Th(dot)Pitschel(at)web(dot)de
> PostgreSQL version: pgAdmin 1.12.3
> Operating system:   Windows
> Description:        error msg feature request for initial server tasks
> Details:
>
> Hello,
>
> thanks very much for this great db package.
>
> On connecting to an older Postgresql server one gets this typical msg:
>
>>>>>>>
> Server instrumentation
>
> The server lacks instrumentation functions.
>
> pgAdmin III uses some support functions that are not available by default in
> all PostgreSQL versions. These enable some tasks that make life easier when
> dealing with log files and configuration files.
>
> The adminpack is installed and activated by default if you are running the
> 'official' pgInstaller distribution of PostgreSQL for Windows and is
> included as a contrib module with all versions of PostgreSQL 8.2 and above.
> However, if you are running any other ...
> <<<<<
>
> This should better read along the lines (CAPITALS for emphasis):
>
> "Server instrumentation
>
> The server lacks instrumentation functions.
>
> pgAdmin III uses some support functions that are not available by default in
> all PostgreSQL SERVER versions. These enable some tasks that make life
> easier when dealing with log files and configuration files.
>
> TO ADD THOSE CAPABILITIES, AN ADMINPACK CAN BE INSTALLED ON THE SERVER.
>
> The adminpack is installed and activated by default if you are running the
> 'official' pgInstaller distribution of PostgreSQL for Windows and is
> included as a contrib module with all versions of PostgreSQL 8.2 and above.
> However, if you are running any other ... "
>
> It is further good to explain what you loose when not installing the
> adminpack.

This is really an issue for one of the pgadmin mailing lists, not so
much here...

-- 
Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

In response to

pgsql-bugs by date

Next:From: Robert HaasDate: 2011-07-20 19:06:47
Subject: Re: PostgreSQL fails to build with 32bit MinGW-w64
Previous:From: Tom LaneDate: 2011-07-20 14:59:15
Subject: Re: BUG #6124: overlaps

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group